20200914 Weekly Release

I don’t think any new issues were introduced in this release! :partying_face:

My Tunic4.val is opening without trouble now! pattern.val is still not working; I don’t personally mind about that one, but whatever the problem is might affect someone else’s pattern that does have value.

The segmentation fault is still happening, but that’s a minor issue.

Of more concern is that the translations, (Greek in particular came up recently,) are still not working properly, (eg. placing a point at half of the CurrentLength. Seamly tries using a string of Greek letters, but doesn’t understand them. Typing the English “CurrentLength” does work.)

But the old, pattern-breaking problem, the Compass Rose Issue, is resolved!!! THANK-YOU DEVS!!! :partying_face: :cookie: :cookie: :ice_cream: :cookie: :cookie:

Is there anything in particular that needs poked at that I haven’t prodded yet?


1 Like

Should be fixed in the next weekly update once the changes are merged.

Like I’ve already mentioned - seems like the seg fault is a Linux build issue. When I get a chance I’ll install Ubuntu so I can test there. Again though, there is something wonky going on with closing a pattern and/or a pattern throwing an error dialog, and then trying to load/convert a pattern. Thing is, it’s only a randomly repeatable error.

I can take a look, but can’t guarantee anything here.

I’m sure as I keep fixing some things and adding new features there will be plenty to beta test. :slight_smile:


Hey Pneumarian… something that came to mind that maybe you could help with… the Wiki could use some updating - specifically right now the changing any reference of Passmarks → Notches and maybe the new way the notches operate. Would you be up to the task?


I can get it started at the least! :unicorn:

1 Like

Ooh, in the preferences the “D” is missing from Notches: Default type:, so it says “efault type:”

1 Like

Do you mean this?


Am I missing something that maybe different with a Linux build? Like maybe a different (wider) font is being used other than the font ("MS Shell Dlg ") set in the dialog form?


Much thanks. I can spend more time programming. :slight_smile:

1 Like

Yes, that.

I think that must be the problem. When I looked at it in the linux VM on ChromeOS, I got something like `ault instead of Default, & “Label font” reads “abel font”. For some reason it uses a very wide, spidery font for the interface.

1 Like

Does Seamly2D work with macOS Big Sur? I tried to download it but it won’t open. I’m new to Mac so not sure if I’m doing something wrong or if it just doesn’t work with Big Sur yet.

1 Like