Deleting points and lines

Hi, I have recently downloaded Valentina and am developing my own patterns. This means I sometimes have to go back and make adjustments to the pattern after making a toile/muslin. I am finding that I am unable to delete some lines and points after the file has saved and the pattern is beginning to look really confusing. I know how to right click to delete items but this option is greyed out. I have tried re-naming the point to see if is connected to other lines but it isn’t - can anyone advise how to delete the points that are now not required. I have resorted to making lots of separate groups so I can hide the points I no longer need but it would be really helpful if I could completely delete the sections that are no longer required. Thanks

You have to check if the points, lines and curves aren’t used as measurements in other parts of the pattern as well.

Instead of redoing the lines, have you tried modifying the formula to incorporate your adjustments, thereby eliminating the necessity for a new point and line?

1 Like

It’s a “sequential” program. This means that each point created has a new, incremental ID. This is also the reason that sometimes you may want to use a formula on an earlier created curve, that uses an attribute of a line that was created later, it is not possible.

The same applies to deleting. Each point is dependent on the other. Which means, that if point ID 999 is used in detail X, you can not delete it. Same when point ID 999 is used by a line or point created FROM point ID 999, you can not delete it.

If you truly want to delete something, then delete everything in the order in which it was created and make sure it is not used in a detail. Then, you can delete.

What grace mentioned should be no problem, if you delete a line or a point or a curve which is used as a formula for another point, line, or curve, then you only need to “fix” the formula (i.e. just type in a random number instead of the name of the old point/line/curve). This is not your problem, it is what I typed.

This, in my opinion is a good thing since it almost forces you to make smart design choices. Always work 20 steps ahead and you won’t have this problem. If the change is so fundamental, that it requires you to delete a lot of points, then just redesign the pattern. It creates less of a mess and be smarter about the design the second time.


This issue should resolve problem with forcing to manually deleting all dependent objects.

1 Like

Delete everything in the reverse order in which it was created :wink:


Hi, thanks for your help. I’ve tried to delete the points/lines using the history window to start with the last item created but still can’t delete anything. Your point about using formulas is a good one as this should eliminate some of these issues. I’ll keep experimenting, sure I’ll get there in the end.

Bonjour il faut bien penser à éliminer la pièce de patron en mode détail si les points ou les lignes que vous voulez suprimer sont inclus dans cette pièce de patron

Have you created a detail piece? An object can’t be deleted if it was used to create a detail.

Post your .val (and &.vit file if you used one)

I had the same issue, then a few days later I was able to delete the point. Zero idea what I did to make that happen but it did not include deleting other lines or points. I assume that maybe it was because I had started mapping out the detail, messed it up because I was just figuring out how it worked, went back and was fiddling with the draw mode. Can you delete the detail record and start over somehow so that the piece is not locked?

If you have changes to a pattern that requires deletions, first delete the detail, then change the pattern and recreate the detail.

You can delete points (and other objects) that aren’t used in the detail. You can delete points (and other objects) that aren’t used to create any objects used in the detail. Essentially, after you’ve created a detail there are very few objects that you can delete. objects = points, lines, curves, arcs, circles

In some cases it caused by bug. When you reopen file an object became again available for deleting.

it’s possible. I wasn’t really paying attention to what steps I took.