AppImage builds fail to run

When trying to run the latest build, I noticed that the AppImage fails to run for me (Ubuntu 21.10). In fact, the last working build for me is Weekly-2021-10-250046.

When I try to run anything more recent, I get the following error:

(seamly2d:22033): GLib-GIO-ERROR **: 10:47:18.464: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'

The other thing I noticed that may be helpful is that the working builds are about 40MB in size, whereas the ones that fail are considerably larger at about 72MB.

Thanks for all the work developing this tool - it’s really useful.


1 Like

Hi @pestrickland, Please download and try this version, and let us know if the issue is resolved or not.

1 Like

Hi @slspencer,

Unfortunately I get the same error when I try to run that version. I don’t know if it makes a difference, but I’m using AppImageLauncher to run my AppImage programs.



1 Like

Related to this bug with GTK and Gnome 4.0: Bug #1922464 “GNOME 40: GTK3 apps crash with: Settings schema 'o...” : Bugs : gtk+3.0 package : Ubuntu

1 Like

@pestrickland Try this fix:

It’s also a problem with Arch Linux - No such key “antialiasing” error - GNOME - Garuda Linux Forum.

1 Like

@slspencer no luck there I’m afraid. That fix seems to have been applied already to my GTK packages.

This is such a weird error message. Apparently it’s a result of all the updates to Gnome desktop, GDK. It happens for Arch, Debian, and Suse distros.

Lots of apps are affected by the changes to the desktop environment with Gnome 40. Here are bug reports for BeeRef & Bottles apps, as GDK3 apps they are supposed to run on XWayland but the OS is running them with Wayland by default:

" The gtk3 and gtk4 packages have the Wayland backend enabled. GTK will default to the Wayland backend, but it is possible to override it to Xwayland by modifying an environment variable:

@Douglas - We might be able to fix it with this Qt setting:

1 Like

@pestrickland What happens when you run this from the terminal:

$ GDK_BACKEND=X11 Seamly2d.AppImage

If this works then update your launcher with this line to get you up and running now:

Exec=env GDK_BACKEND=x11 Seamly2D.AppImage

If these work for you then we’ll export this environment variable in our next build. Hopefully that will be the universal fix

1 Like

Brilliant it works now - thanks @slspencer!

Just one small point in your post - it only works with the lower case x11 rather than X11 in the first example.


@Douglas - I’m adding this export statement for Unix in common.pri, hopefully this can export the variable needed prior to the error condition being triggered. @pestrickland I don’t have a Linux box to test with, so we’ll need you to test the build. Thanks, we appreciate you working with us to find the fix.

1 Like

I’m going to try this, which could be the proper fix for this problem:

QtWayland - Qt Wiki

1 Like

Ah, the easy (and possibly only) fix is to update the seamly2d.desktop & seamlyme.desktop files. :face_with_raised_eyebrow:
None of the available fixes for GTK issues are possible for Ubuntu 20.04, these will be available for 22.04.

We can’t build our appimages on Ubuntu 21.04 because it’s not an LTS and therefore not available on Github. Ubuntu’s LTS’s are every two years, the even years.