Auswertungsfehler - commas and periods

Bei mir ist folgendes Problem aufgetaucht: Eine abgeschlossene Arbeit lässt sich mit folgendem Vermerk nicht mehr öffnen:

2019-05-14-Hose Müller.val (91.5 KB) Größentabelle der deutschen Damen-Konfektionsgrößen.vst (2.9 KB)

1 Like

Kann mir jemand weiter helfen?

1 Like

Hi @Scholli

I have fixed your file. I had to add an item to your .vst file, so I just added a value. Here are your 2 files back:

2019-05-14-Hose Müller1.val (91.5 KB)

Größentabelle der deutschen Damen-Konfektionsgrößen1.vst (3.0 KB)


Dear Grace, Thanks a lot for this. Can you explain to me what happened there?

1 Like

Hi, @Scholli.

You’re very welcome :blush:

t’s a hard one to explain. I found that the instruction for the seam allowance name had changed to **seam allowance1,5 **. The error that you received only mentioned the ,5 but I removed the whole 1,5 and it worked fine after that.


I can’t explain why it happened. It seems that we are getting quite a few strange things happening. I’m only grateful that I am able to fix them. I’d open a bug report if I could understand why it’s doing this type of thing, but as it is, I can’t say if it’s the program, an OS, or something else. So until I can find a bit of logic as to why it’s doing this, I’ll just keep fixing them.

1 Like

@Grace Ich habe hier mal wieder ein Pproblem:( Kannst du mir weiterhelfen und mir sagen wie da wieder passiert ist?2019-05-14-Hose Müller.val (111.7 KB) Größentabelle der deutschen Damen Konfektion.vst (6.9 KB)

1 Like

Gerade habe ich gesehen, dass es sich um den gleichen Schnitt handelt. Ich habe an diesem weiter gearbeitet. Da hat alles immer gut funktioniert. Ich habe gearbeitet, ihn geschlossen und wieder geöffnet. Nachdem er fertig war, habe ich ihn über Layout ausgedruckt:( Ich bin echt ratlos!

1 Like

Hi @Scholli, hmmm it’s again with the union tool :frowning: I see that you did a union (Taschenbeutel Beleg Stoff), just before this union (Taschenbeutel unten Stoff), which isn’t giving trouble. Can you explain to me exactly which nodes you select to create the union, please? I’d like to try it myself because it’s telling me that one of the nodes don’t exist and I’d really like to try and sort this out properly :slight_smile:

1 Like

Here is your pattern back: 6 - Leggings - patron base_v1-a1-aWorking.val (109.4 KB)

I have deleted the Union piece that was causing the problem and it is now working. If you can redo the part, please let me have the details and let me know if it was created successfully.

Thank you :slight_smile:

1 Like

Hallo Grace - ja es hat geklappt. Wäre es besser das Union Teil überhaupt nicht zu benutzen? Ich danke dir vielmals:Herz Augen: du hast mir unendlich viel Arbeit erspart!!!

1 Like

Ich habe die Punkte 88 und 89 als Linie verwendet

1 Like

You’re very welcome. I think you may continue using the Union tool. Just create a separate copy before you use it, just in case it creates an error again. Always work on the original and keep the ‘before’ copy as security. And I really don’t mind deleting the part so you can redo it :slight_smile:

You say you used points 88 & 89 as the line but what are the other points of both of the pieces that you are using the union to create one piece? I’d like to try it to see if I can recreate the error & follow it backwards. It’s the only way I can discover why it’s creating an error sometimes and not other times :slight_smile:

Thank you in advance.

Das eine Teil bestand aus den Punkten: 58-Kurve-79-70-Kurve und das andere Teil wurde mit den Punkten 79-Kurve-88-89-Kurve-85-Kurve-70. Zusammen gelegt wurden die Teile an der Linie 79-70 und nicht 88-89

1 Like

Yaaayyyeeee… Thank you very much @Scholli !!! I have now discovered that the problem is not with the Union tool :blush: :star_struck: :grin: :grin: :grin:

It is actually with the Pin tool :slight_smile:

Here is your original file back in perfect working order: 2019-05-14-Hose Müller.val (111.7 KB)

I don’t know how it happened or why it happened, but it added something to the line when it was created that shouldn’t have been there. At least it will make things a little easier to repair now that I know this, and I can actually repair it instead of deleting the part that is giving the error, so less work will be lost.

Thank you very much for your help in this matter :slight_smile:

1 Like

@Grace, when you are able to get the smallest, simplest file that will duplicate the problem, please let me know. I would love to take a look at it.



I had the same error message: Auswertungsfehler: Unerwartetes Token “.5” an Position 1 gefunden.Programm wird beendet. (Version: 2023.4.17.220/ Git:2604954ca954)

Looks like I was able to fix the problem with your help.

Nur mit Glück habe ich die Position mit dem Texteditor gefunden. Die Formel für eine Variable war mit 1.5 statt 1,5 gelistet. ( In der tatsächlichen Variablen-Tabelle war der Wert korrekt mit Komma dargestellt ) Ich habe den kompletten Wert durch den Wert 1 ersetzt und in der Textdatei gespeichert. In der *.val Datei konnte ich in der Variablen-Tabelle den Wert wieder auf 1,5 setzen. Die Datei scheint wieder zu funktionieren. Danke!

I was lucky to find the position with the text editor. The formula for a variable was listed as 1.5 instead of 1,5. ( In the actual variable table, the value was displayed correctly with a comma ) I replaced the full value with the value 1 and saved it in the text file. In the *.val file I was able to set the value back to 1,5 in the variable table. The file seems to be working again. Thank you!


A possible cause for this phenomenon: In my variable table, the corresponding variable was originally stored with the value 1. For my pattern I set this value to 1,5. I probably just added ‘’,5’'. If I had deleted the 1 and re-entered 1,5 , there might not have been a problem. I will definitely keep that in mind in the future!

1 Like

Make sure the app prefs are set to use the comma instead of the period if the app is throwing an error for 1,5 - which is the default seam allowance width.


Is this a data entry validation issue?
Should the field require a leading 0 to prevent problems?


To me it looks like this.

1 Like