Can’t launch seamly2D on macOS Big Sur

(English below)


J’ai téléchargé seamly2D pour macOS, impossible de l’ouvrir sur mon mac. je suis sur MacOS Big Sur version 11.1. En regardant dans le moniteur d’activité, seamly2D est indiqué comme “ne repond pas”.

Savez-vous si seamly2D est compatible avec mon OS? Si oui, pouvez-vous m’aider ?

Merci Kat


I downloaded Seamly2D for macOS but I can’t open it. My version is MacOS Big Sur version 11.1. When I check the activity monitor. Seamy2D is indicated as does not answer.

Do you know if seamly2D is compatible with my version and if yes can you help me please ?

Thank you for your help



(english below)

J’ai téléchargé et installé sur mon ancien mac qui a MacOS Mojave et ca marche ! Mais mon ancien Mac est appartient à ma société, je ne vais pas pouvoir le garder très longtemps, j’ai donc besoin de votre aide pour l’installer sur le nouveau avec MacOS Big Sur.

Merci d’avance pour votre aide ! Kat

I downloaded and installed it on my old mac with macOS Mojave, it’s working I can open it and use it. but My old mac belongs to my company, so I can’t keep it no much longer. I really need your help to make it work on MacOS Big Sur

Thank you in advance for your help Kat


Oh, dear! Kat. I’m hoping @Douglas or @slspencer will come by and advise you. I know that they are aware of a problem with Mac and that they’re battling to find someone who can test for them, since none of the admins on here work on Mac, so I think they will be really happy if you could help to get this problem sorted. :slight_smile:


Thanks Grace. I discovered seamly today, tested it with a french step by step youtube video and I’m already addict :laughing: I would be happy to help, as I need to give back my old mac to my company soon.


btw, the french user guide redirect to a 404 page on the steamly wiki Do you know where I can find it ?


try this one :arrow_up:

I’ll go see about fixing that link now.


ETA: Huge thanks for pointing that out! Un grand merci pour l’avoir signalé! The links on that page should now all be operational.

1 Like

One more thing @Kat ,

GT: Encore une chose,

I assume you downloaded off the front page.

GT: Je suppose que vous avez téléchargé sur la première page.

Try this link that we think should hopefully work:

GT: Essayez ce lien qui, nous l’espérons, devrait fonctionner: Release Test issue 381 MacOS Big Sur won't open, #2 · FashionFreedom/Seamly2D · GitHub

(I believe you’ll want the .zip)/(Je crois que vous voudrez le .zip)


hi @Kat, The Seamly wiki has User Manuals on this page:


Yes this one is working well thanks ! :+1:

and about the download I already tried from seamly main page and from github, but both are not working :cry:

@slspencer @Douglas, do you have any information about installing seamly on Mac Big Sur ?


Hi @Kat, I’m working on the Big Sur fix right now :smiley:


Sadly my only experience with Mac’s is using Mac Drive to be able to record to and transfer multi track audio recordings to / from a friend’s Mac laptop to my Windows machines.

1 Like

Uh, the open source servers to download Qt for building Seamly on github are down. This will delay the Big Sur fix until the server problem is solved. :frowning: See this article:


Many Thanks @slspencer. Let me know when you think I can try again download it and install it :wink:


Here’s the latest, please try and let me know. If this doesn’t work we may need to hire someone familiar with this problem.

1 Like

Hi @slspencer

Thank you very much for your time and help on this :wink:

I just tried and for now :

  • Seamly2D :white_check_mark:
  • SeamlyME :red_circle:

I tried twice and same result both times

I guess that without seamlyME which manages measures, seamly2D cannot work properly or the measure feature would be difficult to use (even more for newbies as I am) :frowning:

What do you think ?


1 Like

Were the changes applied to both apps? There are separate main and mainwindow files for each app.

1 Like

Hi @Douglas,

Not sure to understand your question. I use the link @slspencer gave me :arrow_double_up: and then I downloaded the zip file

I opened the file and launch the both tools, it seems that seamlyME does not answer (as it was we the previous version).

Did I follow the right process ? If not, please let me know :wink:

Thanks for your help


1 Like

My bad… The question was directed to Susan. I took a quick look and saw the commits only applied to the Seamly2D app and didn’t include SeamlyMe… which I assumed is the cause of the red dot for SeamlyMe.

1 Like

This is fantastic feedback. The environment variable is set in Main.cpp in Seamly2D, not SeamlyME. I’ll go make another update! :smiley: Was getting a bit discouraged…


Well I was aware of the changes you were making in Seamly2D/main.cpp when the build was failing on me, and I saw the green check and red dot and put 2 and 2 together. Hope the next fix solves the issue. :slight_smile: