Cant create a pattern piece

@Grace, @Douglas, @csett86 , good evening together. I just jumped into a new so far for unkown problem. I created all pieces for a bag, consisting of a front part, a back part, two side parts and a bottom part , and a Flapp, the inside consists of a frond and back part, two side and one Bottom part. and some additional pieces. All together 11 pieces. KlaTaBir2023val.val (18.8 KB) enclosed I send you my pattern file.

After creating the ppieces. I wanted to create the pattern pieces with the piece tool.

So I wanted to start with tthe front part , and as soon as I clicked on the new pattern piece tool in the tool box, and immediately after I got the error report and the Programm crashes, The report says

Evaluation error: unexpected Token ".3 found on position 1. Programm is terminated.

I have no Idea what this means. I hope you have a solution for this problem.

Thx in advance


Another user recently had a very similar issue. They were able to overcome it by re-setting the preferences:


1 Like

It’s a math parser error. Not sure why you;re getting the error. The pattern seems to work fine in the windows build.

Which is best done by simply renaming the seamly2d.ini file… test if it works. Otherwise you can revert the name to get back your previous settings. Don’t know where it’s located on a mac, but on Windows it located at: C:\Users\USERNAME\AppData\Roaming\Seamly2DTeam

1 Like

@Douglas , @Pneumarian ,

well I tried to rename the files and it didnt work, than I went back to an older Seamly " D Version without success.

So I reinstalled the latest version.

And Icreated a simple square of 10x10 cm. without saving it, and simply wanted to create a newww piece. And the problem was the same. As I havnt saved the square it couldnt be a problem of the file nam. It must be a problem in the software. I wanted to to create the pattern pieces for a Shirt as a Birthday present for a very dear friend of mine I have the fabric here the buttons and wanted to start on Thurstday. The construction is finished I only need the Patternpieces to print and cut. I guess I have to start the pattern construction with hand drawing on paper , as in former times. BUt I’m runing out of time than.


Were you able to add pattern pieces before? If so what did you change since then and now?

What is your preference setting for the decimal seperator? With OS option or not? Try toggling that setting and see what hapoens.


I tried to open your file under Ubuntu. Only for the points E1 to E5 it seems to be possible to create a piece.

1 Like

Hello @H.Naehmann

I’ve created the 1st pattern piece in my Windows 10 OS. Here is your pattern back:

KlaTaBir2023val.val (21.7 KB)

Please see if you can go into Piece mode and view the pattern and then see if you can create the next piece.

It’s not the pattern. @H.Naehmann stated he tried a 10x10 square, resulting in the same error. Since no variables or measurments are used the only other thing in a formula I can think of to cause a math parser error is the decimal seperator.


:upside_down_face: Oh, ok, @Douglas. Yes, I’ve noticed before that a comma decimal seperator can cause some confusion. :rofl: