Crashes when using "Move Object" Tool

on macOS Ventura 13.1

1 Like

Can you post which Seamly2D build date you are using, and if possible can you post your pattern / measurments. Will helpl us figure out if it’s an outdated app build, in the pattern, of if indeed there is a bug.


Ich habe das Problem auch. Beim Move Tool steht automatisch als Origin Point “Mittelpunkt”. Ändert man diesen nicht wird das Programm beendet. Setze ich einen bekannten Punkt ein, funktioniert alles. :star_struck:


Ah… yes. I’ll make a note to look at that this weekend after I deal with another update that is a priority.


Ok. I took a look at the Move tool… I did a simple test with a move of 3 points with the Center point set as the Origin. I had no issues. I was able to save & load the pattern, as well as changing the Origin point ans saving & loading that pattern. Not sure where the issue can be coming from.

Maybe try my test pattern and see if that produces the error. If not, maybe the issue is related to a more complex pattern… like Moving Move’d or Mirror’d points?

movetest.val (1.9 KB)

And maybe if you can post a pattern that is causing the error.


Das passierte, nach dem ich die Datei geöffnet und den Punkt A1_a1 angeklickt habe: image

In der Liste ist das Feld um den Startpunkt leer:

Ich kann das Feld bearbeiten und einen anderen Punkt einsetzen.


Setze ich jedoch als Start den Mittelpunkt ein, kommt die gleiche Warnung. Setze ich einen anderen Punkt ein, kann ich normal in der Datei weiter arbeiten. Schließe und öffne ich jedoch die Datei passiert dass gleiche wie oben beschrieben wieder. Aus irgend einem wird der eingesetzte Startpunkt immer wieder durch den “Mittelpunkt” ersetzt.


I know what the issue is… when I created the test pattern I was using English… which is why I didn’t have a problem. In checking the “other topic” I switched to German to see if that was the cause there. Not there, but it is here. I now get the same error.


The app is correctly translating the source text “Center point”, but not in the Properties editor - it’s looking for “Mittelpunkt” when the point name in the Properties editor is “Center Point”


Should be an easy fix.

Just have to change

map.insert(“Center point”, NULL_ID);


map.insert(tr(“Center point”), NULL_ID);

where the tr() will create a new source text in the ts files so that drop down will then be translated.


Can I assume you are also using a language other than English? Which would confirm what the issue is.


Famous last words… of course it wasn’t going to be that easy.

Even with the change it’s still creating the item “Center point” in the dropdown in the Properties editor. I suspect the string may be typed as a const which may be preventing the translation to overwrite the text string in the class. Time to dig deeper. :roll_eyes:


Fixed. It was an odd namespace issue due to the way the VToolOptionsPropertyBrowser builds the editor on the fly. It wasn’t finding the context for the translation, because it was inside a (move) Tool class template, which means it wasn’t finding the translation for “Center point”. By placing a translated string in the constructor, the translation is now visibile to the routine that builds the dropdown. :slight_smile:

This may also explain why there are a bunch of “Qualifying with unknown namespace/class” warnings when running Lupdate?

UPDATE: Well, this wasn’t totally unexpected - which is why I checked, but by putting the translation in the constructor, if the language is changed we’re back to the center point not being found. Just have to have the dock retranslate() and reload whenever the language is changed to fix it.


Well that was another fun puzzled solved. I couldn’t stop the warning message from popping up if the language was changed while a Move tool was selected. It was a timing issue between the signal that the language was updated and the data was changed so the editor would throw the warnng. Arggg. Had to have the Preferernces Dialog clear the tool selection and the Property Editor so the language can change, the tool reselected and the Property Editor then opens in the new language selection.

It probably would not have been a big deal, as it’s unlikey that a user is going to click on a Move tool, and decide Hey, I’m going to change the language now… it’s just that there is that outside chance a user does and that warning pops up.



I merged the fix for this issue and it will appear in next sunday’s release… unless you want to a pre-release.


Nein, alles gut. Es reicht das nächste Update :star_struck: