Crest a Layout

Hi everyone and @Grace, can you help with creating a layout? I am not sure what I have done. First of all, I try to crest a label tamplate but it did not work so I have to type in what I deed every time. Second, as I try to create a preview the layout it is empty. What can I do? Many thanks to all!

Ok, first you need to right click on the specific pattern piece and open ‘Options’. Click on the Labels button on the left side and enter the basic info into the boxes where I have placed red arrows: image

To make a long tutorial very short, save the file below into the Label Templates folder:

Basic Label.xml (1.0 KB)


Click on the ‘Edit Label’ button (shown by the orange arrow above). Click on the ‘Import from Label Template’ button, select the file that you downloaded and click on ‘OK’ to accept and again ‘OK’.


Select the Label tab at the top and place a checkmark in the ‘Label Visible’ box and enter the dimensions as indicated by red arrows:


Then you can click on ‘OK’ to close the options box.

And that’s it. You will be able to drag the box to a more favourable position, if you want it printed on the pattern piece and not cut off when you’ve printed your pattern and cut it out.

Later on, you can create a pin to pin the label to or more pins to anchor the size of the label as this one is anchored.

You can also try to add more details to the label or remove some and save the basic label with things that you’d like on your labels.

But for now, I think this is a starting point :smile:

Here my template field is empty as I try to follow your instruction. And I have tried everything but it did not work out. So how can I set up the label tamplate? I have included a pic here for your reference

1 Like

Hello @Angela,

Please download the Basic Label.xml file that @Grace posted.

Open up your windows file explorer and navigate to the folder containing this downloaded template.

Then open up another widows explorer window and navigate to your Seamly2d template folder. Usually, you’d find it in the path C:\Users\Your-name\seamly2d\label templates.

Now drag and drop the label template file from your open downloads folder to the label templates folder.

When you have done that, follow @Grace tutorial from the point below.

The most likely reason you didn’t see results the first time is because you didn’t put the downloaded file in the Label Templates folder.

1 Like

Hi @Grace & @LordRey, thank you for your reply. I have been working on it for an hour but still not worked out what is the matter.

here it shows the label i created earlier. But nothing rather than that. What can I do?

Hi @Angela, download this file to a place where you will be able to find it easily:

BasicLabel.xml (1.0 KB)

Or… Download these 2 files:

Kiddy T-Shirt Pattern.val (38.6 KB)

Aldrich Children 3-6 years.vst (1.8 KB)

Open the Kiddy T-Shirt Pattern in Seamly2D and point the measurements to where you saved the Aldrich Children 3-6 years.vst.

Once you have the pattern open, switch to the Details Tab and open the Options for the “B Back” pattern piece. image

Click the Labels, Edit Template and the “Export Label as Template” button.


This will automatically open the correct path (as specified in your preferences) (See the red square) to save it to. Give it a name… Something like Basic Label. Click on Save and close everything up.

  1. Open your pattern and repeat the process to get to the Edit Template and then click on the ‘Import Template’ button:


  1. It will give you a warning, just click on ‘Yes’: image

  2. Select the template that you just saved and click on Open


  1. Click on Ok and again Ok to close the options box.

You will see that your pattern piece now has a label similar to mine:


Repeat the process from 1 to 4 on the other pattern pieces.

Hi @Grace, tried to download but these are all I can see!

It’s all very strange :frowning:

So… if you click on the blue text… it doesn’t download the file for you?

@Grace, hi Grace, managed to download the file i think. thank you for your help.

1 Like

Hi @Angela,

Did you eventually resolve this? I momentarily lost my internet service.