Detail Piece Not Functioning after Loading New Measurements

I’m still pretty new here, so I’m not sure what mistake I may be making this time.

I have drafted a pattern that has 14 different detail pieces. I have loaded 9 different individual measurements to adjust the pieces to different sizes. I have one more size in which to change the pattern to. It is the smallest size. All of the first 9 sizes worked with no issues at all but this smallest size one of the 14 detail pieces is not the same. and I can’t select the piece even. I’m not sure how to go about fixing it.

This is the piece in both draw and detail mode of the smallest size. Val screenshot3GVal screenshot4

and this the the same screen shots, the only change being that the measurements loaded is one size larger than the previous screenshots

Val screenshot5Val screenshot6

It should be noted that my measurements are correct and I have checked all formulas for error and can’t see any reason why this piece should suddenly no longer function. It’s almost as if it’s a ghost piece I can’t even select it.

My images are JPG. if they are still not showing up (they haven’t in past posts) Is there another way to send them for someone to see what is happening?

After playing around with the program some more, I was able to get it to work. Originally for the largest 9 individual measurement files I had the piece set up with the following order of nodes.

Val screenshot8

I switched the order of the nodes to this. I made no other changes and now this piece works for this smallest size.

Val screenshot7

Is there a reason behind this, so I know how to not encounter this problem in the future?

1 Like

Jpg screencaps are showing ok. Not sure why it would do this… normally it doesn’t matter what point you start at, as long you go along clockwise in the correct order. Can you attach the pattern file and a couple measurement files - including the one that doesn’t work- I’d like to see if I can repeat the error and/or figure why It’s not working.

Here is the File Currently saved in the version that works with all 9 of the largest size files but not the smallest size. I have also included the 2 smallest sizes. It should be enough to duplicate what is happening. Let me know if you need anything more.

Calla 3T.val (95.6 KB) CKC GIRLS 2T cm.vit (1.1 KB) CKC GIRLS 3T cm.vit (1.1 KB)

@caychochang, I am not positive that you caught the full importance of what @Douglas just said about selecting points clockwise. There is one other issue. when you select a curve or arc, you must hold the shift key while you click to select the curve. That is an strange little fact about how the curve is implemented internally. Internally, the arc or curve is drawn anticlockwise. Please try that or let us know that you were already doing it. When I look at the screenshot and see -Arc_A50_429, that might mean that you already know this.

Usually you can see the highlight color as you select points and it should follow your desired path. If it does not work along a curve or arc, it may because you need to use the shift key.

Yes I know curves must also be selected in a clockwise order. and they are selected that way. There is no change between the file working in one size and not working in the next size down, other than changing the measurement file. If I move the last point selected to be the first point selected (so that the order doesn’t change, only which one comes first on the list) it works again.

ok. Good to know that you already use the SHIFT key while you select each curve

1 Like

OK… I played with the pattern and I’m kind of baffled why just smaller size causes a problem??? I didn’t investigate the whole draft, but maybe the smaller size (waist_to_hip_b) goes beyond a point that messes up a calculation and screws up the seam allowances? It’s seems it’s related to point A69 along spline A51_A42_a4. I was able to get it to work by creating a spline that goes from just from A51 to A69… by doing that I was able to start at A69 with no problem.

Note: I added a few things to the side back piece - pins to “pin” the label & grainline and a notch (passmark) at A70. Pinning the grainline & labels it keeps them within the pattern as you change sizes.

Calla 3T_ver2.val (98.5 KB)


Thank you. I’m not sure how the smaller hip to waist measurement might be effecting it. I will need to further examine it. Also thanks for the further adjustments to the pattern. I’m still learning all the ins and outs of this awesome software.

1 Like

it has been well over a month since i had time to draft anything using valentina, but the last time I did I was using individual measurements. I was testing out the pattern with several distinct sets of individual measurements. I had an issue with the fact that certain functions that have two possible mathmatical solutions did not always return the same (e.g. close solution vs distant solution). It seemed to be random, though I did not test extensively to convince myself that it was.

This applied when I was using a method that locates the shoulder point based on the intersection of an arc centerd on the bustpoint and a line that started at the neck opening. With some sizes it was drawn correctly. With other sizes it was misshapen and turned out to be the result of the point being on the other side of the imaginary circle from the desired point.

I hope this description makes sense. I am really tight for time right now, but I am willing to look up the documentation I did at that time if it will benefit someone.


Yes I think that makes sense. It’s ok though. I do not need you to look it up. This is the first full pattern I have drafted in Valentina and I am moving onto another now. If the problem occurs again I will further research the issue. If it doesn’t I will assume there was a simple calculation that didn’t work correctly in that size.

I happened to notice today that Roman (Dismine) made a fix for this on his Repo - so it is/was a bug.

1 Like

Yes he did message me about that. Thank you for the update. :slight_smile: