Details, seam allowence

Hi Im New and I just downloaded the latest version. Im unable to use the detail tool or the layout tool and was wondering is their something I could do to fix it. Also the arrows for the curves are not going clockwise or counter clockwise they’re just set at random.

Hi @jannyrichiez

First you need to select the points and curves that make up your pattern using the Workpiece Tools:


Hit ‘Enter’ to accept the selection and then click on the Layout tab, right click on the pattern outline and select Options to add seam allowances, labels, etc.

If this is what you have been doing, perhaps upload the .val & .vit files so that someone can check what’s happening.

You can either hold the ‘Shift’ key while selecting the curves or reverse the direction when you select the Options (as mentioned above) by right clicking on the curve in the list and placing a checkmark next to ‘Reverse’.

How the arrows on the curve show depends on how you originally made the curve. As @Grace said, you can just press the “shift” key while you select the curve if the arrow is in the wrong direction, this way the curve is taken in reverse direction.

For not being able to use the tool, what is the problem you have; can you finish the line and it doesn’t show or can you not even finish the line? Any error messages? Can you provide the .val and vit?

I believe another example of incorrect nomenclature confusing a user… where one creates a “new pattern piece”, draws what they think are the pattern pieces and then can’t figure out why Detail & Layout mode doesn’t work. < sigh >

With that said… follow what Grace said, keeping in mind to create a “pattern piece” you have to select objects (points, lines, curves) in a clockwise direction and you want to close the piece - that is make sure to end with the last object before the 1st point you selected. Also eventually you need all curves to go in the clockwise direction. If you find you missed an object or added something extra, don;t worry - you can edit the detail list in Detail mode by selecting the piece and using the right mouse button → options. You will see something like this.

You can delete, reverse a curve’s direction, rearrange the order of objects, or make a point a notch (passmark). If you missed an object (or 2) you have to return to Draw mode and select a missing object with the insert node tool;


Return to the Detail mode and you will see the new object(s) at the bottom of the list… you can then drag it/them up to the correct order in the list.

Once you have a handle on creating a detail, and seam allowances, labels, etc… we can help you you with the internal path tool (to make internal paths like the location of pockets) & the pin tool (used to locate labels & grain lines more accurately).

Oops… looks like another bug? the “Export details skipping the Layout stage” tip shows if you place the mouse in the empty area below the Detail Tools area.