Error Bad id - Detail mode


I run Ubuntu 16.04 LTS and Seamly2D and have designed great patterns with Seamly 2D. Nevertheless once I have created details and pattern pieces I cannot close all my patterns through the menu “Window/close pattern” as I have an error message “Error bad id. Program will be terminated. Exception badid : can’t find object, id = 45”. If I close the .val file with the command “File / exit” I do not have this error message. When I open the .val file with gedit I have noticed that the problem comes from this line. It is always the same.

It seams that the detail is not created in the code (systematic error with or without seam allowance, grain line…) pattern_test.val (5,3 Ko)

<detail forbidFlipping="true" hideMainPath="false" id="45" inLayout="true" mx="0" my="0" name="front" seamAllowance="false" united="false" version="2" width="1.5">.

I attach a quick and wrong diagram without any .vit or .vst file with few points for the demo.

The patterns work great but as I am about to share them with .vit files I wonder if people will be able to open and work with them.

Please tell me what’s wrong !

As I have no answer about this issue I downloaded 2 sets of .vit and .val files on this forum.

and tested them. Yes the pattern file can be opened and linked to the measurement file, so they work.

But I will also have to explain to my students that Seamy2D is a curious software as you do not have to “close the pattern” before quitting the application otherwise you get an incomprehensible error message… or maybe there is another reason but the support hasn’t got a clue of what’s wrong.

You’re quite right. I have no clue as to what’s wrong. I’m running on Windows 10 and don’t have these strange errors that you are talking about. However, since it seems that you are teaching students, I’d suggest you install the latest ‘stable’ version rather than the latest ‘test’ version.

I opened your pattern and created the layout and printed it to PDF without any hiccoughs.

pattern_test.pdf (62.8 KB)

Perhaps one of the programmers will see this and have better answers for you.

Thank you ! Even with the stable version I had the same problem. Probably due to linux/Ubuntu. I will soon upgrade to 18.04LTS with a fresh installation. Apparently the files are not corrupted on other platforms. It is just strange that I have to exit and cannot close the pattern…

1 Like

I am not sure if this is related, but I have found that if I open a .val pattern file in any recent version of Seamly2d and that pattern has been previously associated with a .vit file ( the one I tried happened to be in the valentina.measurements.individual folder) any attempt to associate that pattern with a new .vit file by the use of “Unload Current” and/or “Load Individual” will cause Seamly2d to fail by hanging for a long time the asking if you want to stop the process. This does not occur if you ensure that the measurements exist in the exact path where they are stored inside the .val file.

This appears to be related to how the error is being handles when the .vit file is not found

1 Like

Well I am almost sure it is not related. I have the error bad Id message when I work with a .val file with fixed values (no vit files)…
The error ID corresponds to the ID of the tag <detail> :wink:

1 Like

Is this error when you use the menu item - Window-Close Pattern? image

If so, I also get an error using this but it hasn’t bothered me. Each pattern opens in a new screen, so you can have as many patterns open as you wish. I just use the X at the top right of the screen to close a pattern, it will ask you to save the pattern before it closes, if it hasn’t been saved yet. image

I’ll create an issue about it this evening after work.

YES It is THE error I get, I am not the only one ! Normally in any application you first close the current/active document and then exit ! It seems it is a minor error, I am really relieved ! TX

1 Like

Oh, wonderful :heart_eyes: I’m really happy that we have found it. I’ll create an issue but it may be a while before anyone fixes it since we are all doing what we can as volunteers who are dedicated to the program outside of normal activities - hence the program being Open Source. Myself, I try to reply to queries on the forum as my bit towards the program, since I don’t know anything about programming.