"Eurreur d'interprétation de fichier" impossible d'ouvrir mon fichier

Bonjour, J’ai besoin de votre aide sur seamly 2D, je ne parviens plus à ouvrir mon fichier qui pourtant fonctionnait parfaitement bien il y a 2 minutes.

Lors de la dernière manipulation que j’ai faite le logiciel s’est fermé et depuis impossible d’ouvrir mon fichier :confused:

Je vous mets ce que ça m’affiche en dessous de mon message. S’il vous plait pouvez-vous m’aider ? Merci d’avance, Margaux :slight_smile:

"Erreur d’interprétation de fichier. ExceptionObjectError: Erreur lors de la création ou mise à jour de le pièce de patron

ExceptionBadId: L’outil n’a pas été trouvé dans la table., id = 853 tag: detail in line 815 "


Welcome to the Seamly forum! I’m sorry it had to be like this.

GT: Bienvenue sur le forum Seamly! Je suis désolé que ça ait dû être comme ça.

If you would post your .val & measurement files, someone will be probably be able to get it into working order with minimal loss since your last save.

GT: Si vous publiez vos fichiers .val et de mesure, quelqu’un pourra probablement le remettre en état de marche avec une perte minimale depuis votre dernière sauvegarde.

That, combined with the release/build date & your OS, will also help the Devs see about fixing the underlying issue.

GT: Cela, combiné à la date de sortie/construction et à votre système d’exploitation, aidera également les développeurs à résoudre le problème sous-jacent.


1 Like

Bonjour et bienvenue, @Margaux

Je pense que vous devriez télécharger la dernière version de Seamly2D car il semble que vous travaillez toujours avec des Passmarks au lieu d’Encoches et j’ai dû en supprimer un pour les pièces du patron, vous devrez donc le refaire. Il y a également un problème avec l’un des groupes, que j’ai également supprimé.

Ce que je ne comprends pas, c’est pourquoi il n’y a un problème qu’avec certains des Passmarks et pas tous ? Peut-être que @Douglas pourra jeter un coup d’oeil à votre fichier original pour voir s’il peut identifier la raison de ce problème.

Voici votre fichier après corrections :

ChemisevagueA.val (99.9 KB)

Hello and welcome, @Margaux

I think you should download the latest version of Seamly2D because it seems that you are still working with Passmarks instead of Notches and I had to delete one for the pattern pieces, so you will need to make it again. There is also a problem with one of the groups, which I also deleted.

What I don’t understand is, why does it only have a problem with some of the Passmarks and not all of them? Perhaps @Douglas will have a look at your original file to see if he can identify why this is.


Merci beaucoup Grace !! J’ai réussi à ouvrir le fichier, je suis soulagée :slight_smile:

Je vais installer la dernière version pour faire en sorte que ça ne recommence pas.

Vous êtes super :slight_smile:


Yeah… that’s quite an old Seamly version… that was like the first thing I worked on - updating Passmark to Notches. I’ll take a look at the file… I would suspect (if you had problems opening it in a more recent ver) it has to do with converting the old Passmark format to the new Notch format or just one of those edge cases I didn’t think of at the time.

1 Like

Well, just reading through the pattern file on my phone I can tell that object 853 is (or was) an internal path.

Which begs the question… was anything deleted immediately before the file failing to load?


Yes, there are a number of rather strange things happening. Like some of the passmarks not creating an error, and why only the one group needed to be deleted while there are others that are just fine?

C’est un plesier :slight_smile: - My only French.

Avez-vous supprimé quelque chose juste avant de fermer le fichier?

1 Like

Well… something messed up in the < pieces > ( formerly < details >) section. I got as far as opening up in V or Seamly2D ( and converting), loading the measurements, upto creating the pieces (which happens in the background - you just don’t see it because the app starts in Draft Mode) , and then it crashes not finding the ipath id.

Since the schema ver is so old… IMO clearing out the bad stuff like you did and creating new pieces with the current version of the app is best course of action. If it were a case of the new Seamly2D not wanting to load a v0.6.0 pattern I’d be concerned, but since the pattern seems to be broken I’d just be guessing what events led up to it crashing, and I’m not sure what there is to be gained investing time trying to figure out what those events were. If we had a backup of the pattern, and we knew this, this, and this were done leading to a crash - that would be a different story. In other words it ain’t a bug, and you can’t fix it, unless you can repeat it.

I should note I haven’t tried loading your fixed file yet…


Yes, it really isn’t worth trying to find what’s happening when it has already been repaired and won’t likely happen again using the newer version.

Well… since we had a fire at our shop wed morning - which totally destroyed everything - and my internet at home has been iffy - I’ve haven’t been able to post until now. :frowning:

Again I’m not sure what munged up the original pattern. Which again is another reason for me to update the whole backup file thing. Just hope I remember what I all did before.

Anyhow: While I no longer have a need to make patterns, and now have nothing else to do - I worked on updating the Groups today using work from my original fork - I did load the file you fixed and here’s how the Groups show up now:


I should note this will make for pattern version 0.6.8… with version 0.6.7 an update of all the tool dialogs and Property Editor - which I’m waiting for the CI to be fixed again before uploading and making a PR. Both a far cry from the version of Margaux’s pattern - which is old enough to load in Val.


Oh, noooo!!! I’m so very, very sorry.

I think it was because of the older version of Seamly. I used to get very similar errors in the past, that I removed bits from to get them to work. @Margaux has installed the latest and seems to be happily working now.

1 Like

Sorry to hear about the fire!

CI is now fixed on develop, sorry that it took so long!


Ahhh… Thank you very much, @csett86… Alll things in good time. :star_struck:

I am so sorry that has happened to you, I felt completely gutted reading those words and I cannot imagine dealing with that.

1 Like

Dem kann ich mich nur anschließen. :astonished:

1 Like