I worked on my pattern yesterday. As I was finished, I saved it. Everything seemed to be alright. Today I tried to open it again and it won’t work. My old version of Valentina just closed down immediately after saying “QObject::connect: Invalid null parameter”. So I updated to the current Version Now It kind of opens the file, but everything is inactive, I can not do anything… It shows “ExceptionObjectError” I attached a photo.

The last thing I did yesterday was uniting two pattern pieces.

Can someone please help me? This is really important, as it is a work for university… I am very desperate.

Thank you in advance!


OberteilHerrenGrM-2.val (78,7 KB)

Please can you add the .vit (measurements file)?

1 Like

Of course! Thank you for your quick answer :slight_smile:

HerrenMaßtabelleOberbekleidungM.vit (1,0 KB)

1 Like

I just realized that obviously Valentina can not find the related measurements file… I attached a foto. The measurement file is just where it should be and I didn’t change the name or anything. Maybe this is the source of this error? But how can I reattach the file?

If you click on OK, it will let you navigate to the file.

I just realized, that I can not make further comments. As I just registered in this forum, I have to wait 23 hours until I am allowed to answer again :astonished: So I changed this comment to answer on your later comments.

It looks like everything is back! :slight_smile: Doing the details again will be much easier than redrawing everything. Can you send me the fixed file? Thank you very much

This is so unbelievable! I can’t express how relieved and thankful I am! This is a great platform where you really get the help you need. You are great :slight_smile:

1 Like

I’ve managed to get all your drafting back, without the details (Layout).

Could you create them again?




I do have a file with most details, I believe:

OberteilHerrenGrM-2_H(v0.2.4).val (76,4 KB)

Hopefully it works There seemes to be a spline missing in your file.

Die Fehlermeldung ist tricky. Measurements sind ok, so wie es ausschaut, was er sagt ist, es fehle im ein Stück aus detail “910” (das habe ich ganz gelöscht). Ist Dir vielleicht irgend etwas beim Anwenden des unite-tools passiert? Ich versuche mal, das nachzuvollziehen, ich weiß nur noch nicht, wann ich dazu komme.

1 Like

Oh, great :slight_smile: That’s something at least.

It seems that object 887 was created on line 720, but used in the detail of object 910 on line 423. So effectively, object 887 doesn’t exist when the detail object 910 is created.



I can’t think how this could possibly make a difference, since I only make websites and normally the whole script would be loaded and held in memory when one accesses the website page.

1 Like

I coded once, when I was young :slight_smile: I do not remember how it was with Pascal, but in Basic it was really essential to do one thing after the other, because that was an interpreter, i.e. the computer worked line after line.

I think also in Pascal we had to define variables and constants before they could be used although this one compiled. I see Seamly2D or Valentina as like a program, maybe it acts like an interpreter.

1 Like

Yes, it’s a bit baffling that it allowed the spline to be used in the detail and then it put it right at the top of the coding before the object was made. It’s the 2nd instance that I’ve seen of this happening. The last instance, I asked the person if she’d edited the code manually :frowning:

I’m not too sure if an issue should be made about this or even if one could reproduce the problem. Perhaps one of the programmers should have a look.

Here’s the previous one : Error reopening pattern file .val - #28 by ichigolab

1 Like

Ok, so using the same method that I used in the previous error, I moved the detail to the end of the document and it now works perfectly:

OberteilHerrenGrM-2 (1)a.val (79.5 KB)

@GiuliMilk, :slight_smile: have fun.


Now that I can write more answers, I wanted to thank you one more! It works perfectly now. You did great work! :sunny: :slight_smile:

1 Like

Hi @Grace, Do you have about 30 minutes free to add this to our issue tracker on github? You have already done the write up here, just cut & paste, and include a link to this thread. Thanks so much!!!

1 Like