File corrupted afer crash


I was making changes to a jacket pattern I’m working on. I was attempting to add an internal path and the program crashed. Now when I try to open the file I get the following error:

“File error. Exception: Measurement file doesn’t include all required measurements. Please, additionally provide: C0”

If I click OK, I get another error saying that the measurement file couldn’t be found. This is not correct, as I can open that file in Seamly Me. I haven’t changed any measurements of that file for several months because it is the base measurement file for all my patterns.

I’ve uploaded the file. I’m hoping someone can help to recover at least part of that file. I’m not sure what the issue is, but I’ve been working on this pattern for months and do not have a backup.

Is there anything else I should try? Men’s Ranger Jacket.val (102.6 KB)



I got it working. Opened the file with Notepad, found the node containing “C0” and changed it to simply “0”

I think this may be a bit of a haphazard way of doing things and I wouldn’t recommend it but thankfully it worked. I did lose one detail (which contained the “C0” line) but I am very happy to have this pattern back. I have since made multiple backups, including uploading to my Google Drive. If anyone has suggestions of a better way of fixing the file, please let me know. I’m hoping this can help someone out in the future.


Hi @skinnerjeans

No, that is how I would’ve fixed it.

I don’t understand why this happened. Can you let me know if it happens again, including your version of Seamly2D and your OS, please.

1 Like

I’ll definitely let you know if it happens again. I had just deleted the piece in the details window because I noticed an error I made in the pattern. I fixed that one point and tried to add the detail again. Upon clicking the first point of the piece, I got an error message and the program shut down. I don’t remember what the error message was. It didn’t affect any of the functions of the program once I opened it again and it didn’t affect any of my other patterns.

I’m using Seamly version, build revision: Git:287a2d9abe59

Using an older laptop (8 years old or so) running Windows 10 Home.

Hope that helps!

1 Like

Well… what will help in the future is the update to the autosave / backup feature I’m currently working on. Besides the existing autosave / restore function, a user will be able to create any number of versioned autosaves and / or backups… with a means of selecting anyone of those to use to restore the pattern. Basically it’s a means to be able to restore a pattern to some time back in the history before the pattern crashed… eliminating the need to edit / fix the pattern file in a text editor.

Hopefully I’ll now be able to finish off the update by this weekend… upto now I’ve been spending a lot of time dealing with the nursing home, a Medicaid application, my lawyer, and sadly the death of my 99 year old mother the past couple months.


I took a look at the file… it appears the “C0” refers to the seam allowance “after” the referenced node point… not a line. Not sure how the “C” would have gotten in there?

Just as an aside… a node point is a point within a pattern piece’s (incorrectly named detail) seam line / internal path. Node points are created when a tool point is selected to add to the path in creating a pattern piece or internal path.


Thanks for the info! It appears this file has corrupted again but this time for a reason I can’t figure out. I was attempting to add an internal path to a detail this time when it happened. I’m going to assume it’s because I’ve made many revisions to this file including deleting entire pieces and re-building them, such as deleting and changing the pocket shape.

If someone could take a look and see what went wrong (and if there’s any way to fix the file) I would really appreciate it.

Thanks! Ranger Jacket Fix.val (93.6 KB)