Herramienta Line between 2 points

Hola :slightly_smiling_face:

Trabajando con la herramienta Line between 2 points, me encontre con este detalle.

Working with the Line between 2 points tool, I came across this detail.

Cuando toco con el clip derecho, para trabajar con las propiedades de la herramienta, no me muestra en Linetype la opcion (No pen). ver imagen

When I play with the right click, to work with the properties of the tool, it does not show me the option (No pen) in Linetype. view image


Pero cuando trabajo en la misma herramienta, mediante la ventana Property editor, si me aparece. Ver imagen.

But when I work in the same tool, through the Property editor window, it does appear. View image.


Seria posible arreglar este pequeño detalle? :pray:

Would it be possible to fix this small detail? :pray:

Gracias Thank you


Thank you for noticing, @Damay. I’m sure that @Douglas will be able to fix it. :slight_smile:


Correct… since a line IS the tool and it is selectable, if you made it no pen, you would never be able to edit it again.


Yes… another duplicatation of function having to deal with the Properties Editor. I just need to remove the No Pen in the Properties browser. < sigh >

1 Like

And note that the line name is incorrect. It is not Line_A_A.


I believe that this is an older ver, which has been fixed.

1 Like

I fixed this issue… will push the changes as soon as I can.


Muchisimas gracias!!! :slightly_smiling_face:

Thanks a lot :slightly_smiling_face:


Just completed the PR test build for the fix for this issue… should be in this weekends release.

I had the right idea of removing the Line tool “No Pen” attribute in the Properties Editor … just had the code in the wrong spot as drop down items were just getting restored with the defaults - including “No Pen”.


And the fix is merged!
Thank you @Douglas :man_dancing: :man_dancing: :man_dancing:
Next Monday the weekly Release version will be available.


Gracias a todos :heart_eyes:

Thank you all :heart_eyes:


Hola @Douglas. Hola a todos

Primero. Gracias a todos por tomarse el tiempo en arreglar esto, cuando hay cosas mas importantes que resolver en la aplicacion. :pray:

Segundo. La herramienta Line - Between Points esta perfecta ahora :star_struck:. Como se ve en la imagen. En editor de propiedades esta muy bien tambien. pero quitaron de ambas ventanas la opcion de NO PEN que tanto me gustaba :anguished:, pero entiendo el punto que comentaron arriba. Creo que si se usa esa opcion y despues se olvida puede ser un dolor de cabeza arreglar algo en el patron mas adelante. Puedo vivir con eso :wink:

Hi @Douglas. Hello everyone

First. Thank you all for taking the time to fix this, when there are more important things to solve in the application. :pray:

Second. The Line - Between Point tool is perfect now :star_struck:. As seen in the image. In property editor it is very good too. But they removed from both windows the NO PEN option that I liked so much :anguished:, but I understand the point that was commented above. I think if you use that option and then forget it, can be a headache to fix something in the pattern later. I can live with that :wink:



Hello, @Damay

I normally make those lines into a dotted line and change the colour to a pale yellow or something really light so that I can only just see it and it’s not in my face all the time :grinning:


Now that Groups are properly functional, one may also place all lines that one might not want to see into an invisible group of lines.

GT: Ahora que los Grupos funcionan correctamente, también se pueden colocar todas las líneas que no se deseen ver en un grupo invisible de líneas.



Just a note folks… Soon I’ll have the “groups” attribute added to the tool dialogs so you will be able to put the new tool right into a group when you create it. Default being No Group. Plus you will be able to select whether any of the pen styles (type, weight, or color) are to use the “By Group” attribute. This way you can create groups with a given pen style… say “Contruction Lines” that are Pale Yellow, Dotted, and 1.00 mm wide, place new tools in that group, and then have control over the visibility of your “Construction Lines”.

Here’s the 1st tool I got working… Point - Length and Angle dialog. group_dialog


Yes, they’re already working very well. I love the new groups.

You’re a :star2: . @Douglas. I can’t wait!!!

Yeah… this will really help speed things up as you can just add a tool to a group as you go while the dialog is already open. Short of the few tools that don’t open a dialog upon creation. I’m just working on this in parallel when I get stuck as what to do like I currently am with the iPaths in the Union tool - which is kinda of a mess. Which I can see why there has been unexplained crashes with it.

1 Like

Yeah… I’ve worked my way around avoiding the Union tool for so many years now, I don’t even see the icon any more. I really believe it’s allergic to me :rofl:

He he. Yeah… it’s all very strange… where the new “union” piece take ownership of the piece #1 internal paths, but adds a copy of the piece #2’s paths (as it should)… so then if you retain the pieces the ipaths disappear from piece #1 as they are now parented to the Union… BUT there is still a reference in the Paths->Internal Paths for any ipaths in the Piece Tool. Then there’s issues trying to delete paths as the referencing / dereferencing is all messed up. Add to that there’s that unused “In Use” attributes… as well as the < chidren > < child > elements that make no sense. try and figure out what < child > node is what… you can’t unless you’re running through the debugger to see what point the node really is. It’s this whole added layer that doesn’t need to be there. A Union just needs to be treated as if were just another < piece >, and they’re not. And that’s why I’m stuck fixing the Internal Paths at the momment without fixing the whole Union tool… or I could just delete the whole Union tool - problem solved. LOL


If it were up to me, I’d say this is an option.

1 Like