How to add a notch where 2 pattern pieces unite

Hi there, newbie here. I have used the union tool to join 2 pieces (front and back of raglan sleeve) and now I would like to put a notch where it unites at the top of the sleeve (to match the shoulder seam). Where the pieces meet, there are 2 points, so I added a passmark on both, but I don’t get anything, no notch showing. Is there a solution for this? Thank you in advance for your help.


Hello and welcome to the Seamly2D forum, @Camimade

I’m going to hope that someone else will come and reply to your question because I avoid the Union tool like the plague :rofl: - but that’s just me.

I prefer to do all my unions in the pattern drafting using the Move, Mirror and/or Rotate tools, to create copies of the pieces and join them. This way, you have a full set to add notches wherever you please :slightly_smiling_face:


Hmmm… interesting question. I’ll have to play with it later when at home, and I’ll get back to you. :slight_smile:

1 Like

Hi Camimade,

I made a test with two simple draft pieces. Added notches where they would meet. Joined them, and the notch appears automatically. So your pattern has some differences.
Please post your pattern & measurement files so we can troubleshoot.
Thanks! (I’m in Windows with the build from Nov 28)


Well, I made a similar test… discovered some things interesting. I intentionally made the notch type at A2 different for each piece AND lo and behold it added 2 - A2 nodes in the union main path, each with it’s respective notch type. Thing is, if there are 2 nodes with the same name NO notch is displayed. You have to exclude one of them for the notch at that node to show.

Which brings up several questions.

  1. Do I make the union tool keep both duplicate nodes?

  2. If not, which node should go?

  3. If yes, should one be added excluded?

  4. If yes, which one should be excluded?

  5. In any case should I attempt to create a message box that presents the duplication and asks the user what action to take? Maybe along the lines… “There are duplicates of Point xx with different notch types. Which notch type do you want to keep?” Type 1 Type 2. OK / Cancel.

1 Like

I think that option 5 will be great, but without a cancel option, because one should only be able to exit after choosing either 1 or 2.

Ok, so this is an edit…

I’ve just been looking into the Union tool and noticed something. In the Options, all the nodes are listed in the order of creation of the piece, so the 2 pieces that are joined, all the nodes are there except the adjoining piece’s 2nd node, and both of the 1st nodes are there (both the 1st piece chosen & the 2nd piece) and these are the 1st and last nodes in the list.

If you choose to place a notch at the 1st node, then it doesn’t show until you Exclude the last node.

image image

I’m wondering why there are 2 x A15 nodes - as the 1st & last - while there is only a node A30 (in other words, only 1 node, since A31 isn’t listed)?


If one can exclude the 2nd node of the 2nd piece, then one should also exclude the 1st node of the 2nd piece. Then there wouldn’t be a question about how to place notches or which notches need to be placed.

1 Like

That would be what one would expect. And the A2 point in my example was the 1 node selected for each detail (and yes the term needs to change to “piece”).

So now I have to see what happens if both selected nodes have different notch types.

Bigger question is… could some of issues with the Union tool be this extra duplicate node? Where point usage is not getting incremented / decremented correctly. Hmmm.


I wonder if it’s the fact A15 has 2 different notch types? Or if by coincidence we both happened to make an example where the second node selected happened to have different types. That why I said we need to see if we make node 1 of each piece a different notch type what happens.

Update: Well… I did just that with my above example, and now I’m really confused. I tried different combos of notch types, and that has nothing to do with the duplicate node. I also tried different combos for the 1st and 2nd nodes for each piece, and it always produces a duplicate A2 node. ??? I then looked at the paths for each piece, and in both cases A2 is in the middle of the path. ??? I even moved node order around in the paths… and it’s always just a duplicate A2. ??? So 1st / 2nd, first / last, notch type does not seem to matter.


Very strange. I tried joining from the other angle:

The 2nd part of the union, 2nd notch (A50) doesn’t appear in the list nor on the piece.

But both A2 & A7a, which are the 1st nodes of the 2 pieces, appears at the bottom of the list now because of the way the pieces were created & joined:


Now we have 2 nodes on top of each other.

And A2 has no SA after while A7a has no SA before, so the SA of A7a is continued and the A2 is ignored.

1 Like

Thank you all for your replies! I have played a bit with the united piece, and one of you said, by excluding one of the 2 points that are meeting, the notch appeared. I was using the same notch type for both points.


:sweat_smile: I’ll try the unions in the pattern drafting next time!


:rofl: @Camimade, I have an idea that unions are allergic to me, so I avoid them out of respect. But I would’ve still replied to you if I’d had the time. We have loadshedding here in South Africa & my wifi was about to die, so just wanted to let you know that someone will reply.

However, this has brought out some things that @Douglas is looking into that will improve the feature & perhaps make it less allergic to me.

All the same, it is a very lovely tool and is great for checking if your curves are true, so it’s up to you whether you will use it or do it my way. :smile:


Yeah… there’s something strange going on with the Union tool. I played with your test, and the couple unions I tried there were no duplicates??? When I finish addressing a few other issues I’ll have to take a deeper look into what’s going on in the tool.

The one thing I also noticed in the tool is if in my test I joined the 2 pieces by A_A2 and A2_A1, I got duplicate A3’s… which sort of makes sense, but you would think in that case the “copy” node should be suffixed like the Op tools… like A3 and A3_2 or something.