Is a nameless point possible?

Hello I am new here and I just discovered Valentina, I enjoy it a lot already!

My first question is if it is possible to create a point without giving it a name?

Sometimes there are points you use as reference to build other lines and points around it but which are not that much relevant. If I let the field for the name empty, it wont let me save the point (or I am doing something wrong?)

How can I create the point without adding a name?

Thanks a lot for your informations. Noukita

1 Like

You are not doing anything wrong. A nameless point is not possible. The software must have a name to keep track of each point internally. You may assign a name to each point. Seamly will automatically assign a name. You are free to use the default name (usually something like "A1, A2… B1, B2… etc) You can assign meaningful point names to whatever points you wish. This answer applies to both the Seamly2d program and the Valentina program.

Please note that I called the program by its current name, Seamly. You will note that on this page at the top, the name of this forum is the Seamly2d forum. The URL that shows in the browser window, “” will be eventually changed as part of the rebranding process. Please bear with us as this happens in a way that attempts not to leave behind any existing users.

If you choose to use the Valentina program instead, please see which is the forum to support that program.

If you are just starting out, you might want to check to see that you are using the most current version. To get the most current version, click the “Download” item at the top of this forum page, enter your email, and download the newest version.

Last summer, the project had a “fork” which means one branch of the project continued on with the name Valentina and another branch is in the process of renaming and rebranding itself as Seamly2d.

This forum will continue to provide support for the Seamly2d product. If your questions are relevant to both, someone here is likely to know the answer and will help you. (We are a friendly bunch). If you continue with versions of the Valentina program it is likely that you will encounter issues that nobody here will know an answer to share with you.

Meanwhile, welcome to the forum. Please feel free to post an introduction under the topic “newbies” if you would like to get acquainted.

1 Like

Welcome @Noukita, You can create a group of the points you don’t wish to have visible by using the group tool under operations:


Name the group perhaps ‘Hidden Nodes’ and then you can switch the ‘Eye’ next to the group (on the right side) on and off at will. Whether the ‘eye’ is open or closed, the nodes will be available to you.



Dear kmf, dear Grace,

Thanks a lot to you both for all those interesting and helpful informations! And provided so fast too :slight_smile:

I am looking forward using Seamly :wink: as soon as I can, I think I will manage with the new hidden group.

Thanks again and have a nice day, Noukita

Hi Grace

Back home I wanted to try your suggestion.

I easily found the tool on the left margin of the main window to create a new group and could name the group too. But after having done that I can not see the panel “Group” where I could chose to show or to hide the content of a group? I tried through the menu “Windows” on top (I thought maybe the group had been hidden without me noticing it), but there, I only have something called “close pattern” (This just made - as expected- my pattern close and disappear).

Do you have another hint for me?

Thanks in advance! Noukita

Sorry, I only saw this now…

On the right side of the drawing area, there is an area called Tool Options. Right-click on the gray area next to the words, it will bring up a menu where you may place a checkmark next to Group. That should turn it on so you can see it.


If you don’t manage that way, you may use the menu at the top - Click on Pattern-Piece and then the Group item at the end:


1 Like

hello together, I have followed your questions and answers with interest. I work very well with the groups. However, to further develop the cuts, the dot names are getting longer and longer: they are on the screenshot. Is there a way to give the points a new assignment to the finished, new model? That would simplify a lot :slight_smile:

Yeeessss… Hmmmm… Ok, when you move/flip/rotate a piece, it gives the option to add ‘a1’ to the node label so you can follow where it came from. The first 2 (or more) characters are the original node label that is being copied and the last 2 characters are what are added. So if you are creating multiple steps, using the previous one, the label will get longer and longer. The only thing I can think of is to always use the original nodes that were drawn. But I agree, it’s not always possible to use them :disappointed_relieved:. As a suffix, you always need to use 2 characters. They could be only numeric if you wish, as long as the same combination hasn’t been used before.

So you could start with 01 but it won’t shorten the labels.

1 Like

I’m trying out the following: I’ll see that I’m making new points in the process. I can do that by using the length. Is a little effort, the number of points is higher, but do not take so much space away :slight_smile:

1 Like

Another thing to remember is that if you want to actually rename points after they are used, you will get errors. The lesson here is to rename the points as you create them. I have had to start from scratch and recreate a pattern if I want to have meaningful point names in the drawing.

I also find it useful to remember that the printed pattern piece (created as detail) are not the same as the components used to construct them (created in draw)

This is comparable to drafting a pattern on paper and having many lines and marks that you will ignore when you cut out a reusable tissue paper pattern (if you do it that way)

1 Like

Hi again Grace, yes, that exactly was the problem, the grey space for tools and groups was not checked any more, I was not aware of changing it myself but I remember that at the beginning I had the space for the tools at least, so it can only be me who did something :wink:

Apart from going to the windows menu, I tried to right click on the left side of the pattern but nothing had happened. Your clear indications with screenshots solved perfectly my issue and saved me from loosing more time searching at the wrong place.

I have all now again after I went to the Menu “patterns” - that’s perfect! Thanks a lot.


1 Like

Thanks too kmf!

It is good to know, especially as beginner, and I will be extra attention not to change the name of points afterwards and think well before I name my points :wink:

1 Like