Keeps freezing

when I try to change the formula on A48 it freezes.

dain jacket change sleeve.sm2d (213.7 KB) dain 031224.smis (2.1 KB)

1 Like

Can you be a bit more specific? I downloaded your file and could chance the formula.

1 Like

i was trying to change it from @bicep/2 +4.2 to @bicep/2 +4.15 and once i clicked out it just kept spinning.

1 Like

I can confirm that it’s frezzing on me, but I’m still looking at the pattern to see if it’s a bug or something wrong in the pattern piece path.

In the mean time I noticed a lot of unecessary points - specifically related to notches.

You don’t have to create 2 points for a double notch:

Screenshot 2024-04-16 231809

You can set the “Count” in the Notch geometry to 2 for a double notch.

Screenshot 2024-04-16 231838

Screenshot 2024-04-16 231812

Changing the width sets the space between the notches:


Changing the length changes the length of the notch and you can have a max of 3 notches:


And you can set the default setting for Notches in the App->Preferences->Pattern->Notches


Clicking the Reset button resets the value to the default setting.


The Angle attribute is currently only available with the Slit notch type… the others produce anomalies when used on a curve.

I’ll let you know what I come up with the freezing.


OK… this is the second bizaare anomaly I’ve seen in the last few days.

I can change the formula to @Bicep/2 + 4.14 or @Bicep/2 + 4.16 and it works fine. As soon as I type in @Bicep/2 + 4.15 it freezes. I also tried @Bicep/2 + 4.151 to see how close I can get and it froze as well. Also typing in 12.9… which is what @Bicep/2 + 4.15 equals… it freezes. I also edited the pattern file to @Bicep/2 + 4.15 and it won’t load the pattern and freezes. I tried channging the length of Line_A36_A32… no luck.

What did work was changing the Formula for A32 to @cap_height +0.5… which then changes the geometry of A48 to A20 to A32. Obviously you wouldn’t want to change the cap height, but I did it to narrow down the issue. For some reason it just doesn’t like the 12.9. ???

For now if you can live with the difference of a 100th of an inch I’d just use 4.14 or 4.16. I’d have to run this pattern in debug mode and step through the Intersect - Arc & Line tool to see where the issue is.


i noticed that it was the 4.15 too. i ended up going back to a different version and it seems to have fixed itself.

1 Like

Well…it’s good that I looked deeper into the tool’s code, as it probably has issues. There is a case where if it doesn’t find an intersection point it returns a QPointF()… meaning no point. It’s one thing if the tool has no depemdents, but No Bueno if it has dependents as it’s going to crash or in this case get stuck in a loop.

Looking even deeper… just as I suspected the tool is using a routine that uses fuzzy math. May be able to fix the issue by using a bit less accuracy when finding the point. When using real math you get rounding errors and can’t depend things being equal when comparing 2 values. One may be 12.9 and the other 12.89999… so you have to say if they are within ±.00001 they are equal. In this case we’d probably have to lessen the accuracy. It’s like calling balls and strikes in baseball… how big is the strike zone box. :slight_smile:


@Emily - Which version had the problem, and which version didn’t have the problem? Also, are you Windows64, Window32, Linux appimage, Linux flatpak, or MacOS64?Thanks!

1 Like

I think she meant different version of the pattern. The freezing issue is most likely related to a fuzzy math issue that’s going to be in every build back to the start. Whenever you can change a value by a couple hundreths or thousands and it works - it’s usally a floating point rounding / fuzzy math error. I think I can eliminate a lot of these random issues by reducing how accurate we’re trying to be in the fuzzymath routines.

1 Like

mac os. i meant going back to a different version of the pattern.

1 Like

BTW… with the latest release with the updated About dialog you can click the Copy to Clipboard button and then paste the copied build & system info to a bug report or here in a topic. :slight_smile:


Seamly2D version: Seamly2D
Build revision: Git:bcb817291b40
Build date: Built on Mon Apr 22 2024 at 00:13:23
Qt Version: 5.15.2
CPU: x86_64
Compiler: MSVC 2022 64 bit
CPU: x86_64
OS: Windows
OS Version: 10
Locale: en_US
Country: United States
Language: English
Script Name: Latin
Decimal Point: .
Negative Sign: -
Positive Sign: +
Direction: Automatic
System Codec: System
Arguments: D:\Github\build-about_dialog-release\src\app\seamly2d\bin\seamly2d.exe

This is why artchitecture uses mm as its universal measurement unit and rounds everything up to integers.

1 Like