Let's test new tool Symmetry

Hi all,

I have finished developing new tool Symmetry. As always test and say what do you think.

These two new tools work very similar to the tool Rotation.

1 Like

Cool tool. Works very nice. Just in time for me. I was really need for it.

Needs a little explanation. I had 2 simple curves to mirror and of course I selected both ends of the curve, but I cannot select the points used for the symmetry. I took awhile to figure it out.


Yes, exactly. You cannot select such points. Same rule works for the tool Rotation too.

Okay, thank you for your feedback, i will improve tooltip for tools.

I have tested the tool and it worked very well. I had a crash at some point but after that I tried really hard to reproduce it and I couldn’t. In the error message there was something about an id that didn’t exist. Unfortunatly I didn’t think in the moment to make a screenshot. If it happens again I will report it.

It was the first time that I used any tool of the “operations” and at first I didn’t understand that I had to press enter, because I didn’t notice the tool tip down. Once I noticed it and saw what I had to do I was perfect.

Maybe the Tool tip could be made a bit more visible (for instance another color), when using a tool for the first time? In order to draw the attention of the user?

That’s pity.

If this will happen again think about what you did not about taking a screenshot.

No, this not make any sense. The app can’t know your experience. This is task for good user tutorial or something like this.

yes, if it happen again and i can reproduce the steps that lead to the crash, i will include thoses steps in the report. A screenshot of the crash-dialog is probably useful as well.

Yes that’s true, if the user was taught to look at the tooltip in the tutorial/user manual, then everything should be fine.

I am having problems with the tool as well. It actually worked a few times, but today I could not get it to work at all. I am using the latest test version downloaded yesterday on a mac.

Here’s what happens. I was trying to replicate a waist dart which is made up of two lines.

  1. I click on symmetry tool (mirror on axis for example)
  2. tooltip says to select an object. I selected a line (and a dotted rectangle appears around it)
  3. I tried using shift / command key to select another object (the other dart line) but nothing happens. The tooltip doesn’t say which key to use to select more than one object but I am assuming it is one of this two. Anyway nothing happens, so I give up and was going to mirror the lines one at a time, so I click Enter
  4. Then this pops up and then the program crashes.

The same thing happens when I use the other symmetry tool (mirror by line). Just that every time it is a different id number reported.

Thanks, i think this will be enough for me to release a patch.

Sorry, i should ask again. Did you build the code or downloaded it?

If i am right i made a fix couple of days ago. Here https://bitbucket.org/valentinateam/valentina/commits/14304595f4c4ddafbfb23d6c7c78b851b92ff082. The commit was made 2016-10-04. The last test build from download page dated 2016-09-28. So it does not contain the patch.

Just do not select lines if you use the tool and all will be fine.

Hi, oops sorry, I don’t know how to build the code. I downloaded it. :blush:


Thank you! Will try it out.