Measurements diagram missing

Hie I am a nebie in here I just trying to draw patterns The first question is why in seamlyme i can not see the diagram and also why in preference there are three dirs that the installation program doe not create Thank you for your time

1 Like

Which OS do you use? Windows? MacOS? One of the Linux distros? & which version?

I believe the directories are created as-needed, they certainly can be, though as you indicate, it would be reassuring to see them at install.

@slspencer I wonder if the diagram issue is related to the language issue. I have the same problem on my Chromebook, but since ChromeOS isn’t officially supported I didn’t think much of it, I can see the diagrams on my main (Ubuntu Linux 18) computer with an older install.

GT: Ποιο λειτουργικό σύστημα χρησιμοποιείτε; Windows; MacOS; Μία από τις διανομές Linux; & ποια έκδοση;

Πιστεύω ότι οι κατάλογοι δημιουργούνται ανάλογα με τις ανάγκες, σίγουρα μπορεί να είναι, αν και όπως υποδεικνύετε, θα ήταν καθησυχαστικό να τους δείτε κατά την εγκατάσταση.

@slspencer Αναρωτιέμαι αν το ζήτημα του διαγράμματος σχετίζεται με το ζήτημα της γλώσσας. Έχω το ίδιο πρόβλημα στο Chromebook μου, αλλά επειδή το ChromeOS δεν υποστηρίζεται επίσημα, δεν το σκέφτηκα πολλά, μπορώ να δω τα διαγράμματα στον κύριο υπολογιστή μου (Ubuntu Linux 18) με παλαιότερη εγκατάσταση.

My operating system is Windows 10 And the language I’m using is greek if he can fix it with another language I don’t have a problem using English does this solve this problem?

1 Like

Hello & welcome back, @yiannistamv.

Have you tried turning the diagram on? image

I always make my own directories in a folder on my desktop, so I can find them easily. This way, when I’m helping people on the forum, I don’t have to go all the way to the C drive and then the programs, etc. etc. :slight_smile:


1 Like

Yes I have tryed it I cannot see the picture as for the dirs I did create them I just wonder why the installation program does not create them

1 Like

Please send me your measurements file so that I can see what it’s doing. :slight_smile:

1 Like

that’s what i get no diagram at all


Wow! that is very strange.

I think @Pneumarian is correct. It is a similar problem to the one with the languages that is only with new installations.

I’m thinking that the programming team are currently working on these bugs that crept into our new release and soon there will be an update released but I’m not too sure if it will only be Linux or will it include Windows, as well: 20200619 Linux Appimage Test Build! - #10 by Frederico

In the meantime, perhaps you can reference the images from the lists here: Measurements - Seamly2D

I have created an issue for this: Measurements Diagrams not available in SeamlyMe in new installation · Issue #273 · FashionFreedom/Seamly2D · GitHub


Yes the images and translation files were not included in our latest build instructions. We are working this issue as quickly as possible.

Thanks for your patience!


ok it’s fixed – Download the New Release with Translations & Images FIXED!


Hi, measurement diagram still not appearing in linux ubuntu 20.04, using seamly2d (date 15.03.2021)

1 Like

Hello @mak485, and welcome to Seamly2D’s forum.

I’m on Windows, so I can’t help - perhaps @Pneumarian will be by in a bit with some advise.

In the meantime, you may download the latest release (& see if that will fix it) here: Release Weekly release 20210510 · FashionFreedom/Seamly2D · GitHub

The most recent release in which the diagrams do appear in the AppImage is Release Weekly release 20210104 · FashionFreedom/Seamly2D · GitHub

@slspencer the function seems to have been broken again in the Release Test issue 382 and 383 fix paths to resources · FashionFreedom/Seamly2D · GitHub With that release a warning message also is introduced when opening SeamlyMe: QFSFileEngine::open: No file name specified -even when opening via the Edit Current menu option, in spite of it successfully opening the current measurements file.

1 Like

Hey I’ll go look into this problem right now. It seems this happened before.


Probably should check the Windows ver too… I know this was an issue with the Windows ver in the past. I’ll check on my laptop later when I get home to see what the latest release is doing.


Just checked this weeks release and the Windows version looks fine for the measurement diagrams.

1 Like

OK I fixed the links on the website to be an older linux appimage with diagrams. We’re re-creating the linux build pipeline from scratch - hope to have it fixed this week, fingers crossed.


hi Pneumarian, thanks for reply. r20210104 is working fine.


The issues still remain with the 20210521 test release.

There’s also an issue in the Windows ver… I advised Susan on a solution. We should be able to resolve the issue.