Multiple bugs on Linux


So I’ve made a snap install of Seamly2d on Ubuntu (that wasn’t a straightforward manipulation, it seemed like I could only run an image of the sofrware and installing a persistant copy seemed like a forbidden tweak, have I missed something?) and there are multiple issues for me atleast.

First, when I launch the program I get an error box : “failed to lock /home/…/ seamly2d/config/Seamly2DTeam/seamly2d-pid2.log” . I can close it and open the software apparently just fine, though.

Then when I open a project or seamlyme, I get the error message image I have to close them 8 times to keep going.

Then, there’s a visual quirk with the dark mode in which I am working (may be a native problem related to my color setup i don’t know) : text is white on white boxes and I can’t read anything image

And finally, the file explorer don’t seem to see /media in the OS infrastructure tree… So I can’t record anything on my data dedicated HDD.

Is anyone else having these issues?

(PS : sorry for the broken english)


Hello and welcome to the Seamly Forum, @moe

Unfortunately, I can’t help you with this problem. Perhaps @Pneumarian will be along shortly to assist.

In the meantime, I believe that this is the link to the latest installation that installs from Flathub. Perhaps it will work for you.

1 Like

Sorry, I don’t have time for more than a rather brusque glimpse right now:

Seamly isn’t optimised for other than light modes yet.

I don’t use snaps as much as I can help it.

On my Devuan machine I install with:

sudo apt install qt5-qmake qtbase5-dev libqt5xmlpatterns5-dev libqt5svg5-dev libqwt-qt5-dev g++ qtmultimedia5-dev
sudo qmake PREFIX=/usr -r -d CONFIG+=no_ccache CONFIG+=noDebugSymbols
sudo make -j$(nproc)
sudo make install

from the source folder. Which I originally did on an Ubuntu machine, but for some reason it didn’t work on my other Ubuntu machine, & I haven’t tried too much because I have it set up with the folder containing the AppImage open. Same with my chromebook.

As to the /media issue, my only guess is that the disk hasn’t been activated in the file system? I activate my file drives as part of my normal bootup routine.

I’ll try to post a better reply when I have time, if @csett86 & @Douglas don’t beat me to it. @csett86 maintains the flatpack which Grace mentioned.


1 Like

Since I’m not a Linux user, all I can add is to confirm that yes - the app doesn’t support darkmode at this time. While I can probably fix the dialog in question - I’m sure it’s probably a stylesheet issue - there are many icons that will not show very well without an overhaul. Also, you’re likely to have issues seeing the draft lines as the app does not adjust, that is, flip the color depending on the background.


Hello, thanks for your answers!

I tried I think all the possible installs with the same results unfortunately.

Of course my drives are mounted to boot automatically. The OS sees them fine and I can navigate them perfectly fine through dolphin or the terminal but seamly2d don’t even see their mounting point (/media)

Understood for the dark mode… I’ll try to change that and see how it goes. Though the lines in the drafts appear tone on tone but just fine!


The flatpak might have trouble seeing media, but at least the AppImage should work fine.

May I ask: What linux distro, version and desktop environment do you use?


Of course, I’m on Ubuntu studio Version 22.04.3 LTS Jammy Jellyfish and it’s KDE Plasma


Hello, I’m also using Ubuntu Studio, my version is now into 23 and I can confirm the same problem. If I remember correctly it began when I made the change from Kbuntu to Studio… I never posted anything for it because I could click past the errors and still use the program and I thought it had to do with an install problem personal to me. After going through lots of Seamly updates the problem is still there and it’s nice to see it coming to light. If it is specific to Ubuntu Studio I don’t know enough to self-diagnose but I do hope it can be cleared.

Good luck.

Edit: If I remember correctly when I first encountered the problem the Appimage was giving the same problem… But right now I downloaded and tried the appimage and it seems to be free of the error.


EDIT: NEVERMIND PROBLEM STILL THERE, It just comes when I try to OPEN something

Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server”

Appimage is fine, no error encountered when opening.

Edit 2: The failed to lock error is actually the same as the original poster, so all errors were the same as original post except i haven’t checked image stuff. The reinstall seems to have actually cleared the failed to lock error! so not all bad.

------post before edit---------- I actually just uninstalled and deleted old settings then reinstall the latest Seamly flatpak and that seems to have cleared all error popups.

Also, before the reinstall the error was actually a little bit different than the Original post. But the original post error WAS the exact same as i remember getting when the problem first started. It may be specific to Ubuntu 22, not 23.

Sorry if i added to a false reading of the problem, but I am glad personally to be free.

1 Like

I tried the Seamly AppImage 2024.1.15.150 on Ubuntu 22.04.3 (not Kubuntu, not Ubuntu Studio yet), and there opening pattern files from an external media (a USB stick in my case, mounted /media/…) worked without any errors or issues. Saving there also worked without any issues.

When using the flatpak, I got the one-time popup about the failed to lock ...seamly2d-pid2.log, but clicking OK there was fine.

I first could not access /media, but I found a workaround:

Running with --filesystem=host allows access:

flatpak run --filesystem=host net.seamly.seamly2d

This then also worked to access patterns on external drives.

I will try again with Ubuntu Studio and Kubuntu, there seems to be an issue somewhere there.


Oh thanks a lot, it worked!

I finally dumped the flatpack install, though, because even though I sucessfully relocated the files, I had to launch it through the terminal if I wanted to load an old pattern.

So I downloaded the appimage and pined it to my taskbar via KMenuEdit and all is well. Not even a single error when loading the patterns.

One reliable way to fix the problem!


Hi again,

I didn’t have the /media problem but I ran the command anyway and since it runs from terminal I noticed more previously unseen error which may or may not help diagnose the problem.

1 Like

Thank you for the updates, @ChisaoMusician the dbus errors can be ignored. I dont exactly know where they are coming from, but they are fine hidden in the command line, it was a temporary issue that they popped up in the GUI, but they have probably always been there hidden in the command line before that.

But good to know that Seamly is now running fine for you.


Yes the Appimage is a great work around and works perfectly, thanks.

Did you notice the things before the Dbus errors? It seems to come right before the “locked” error (which came back).
Particularly this with the “Failed to create wl.display” and “could not load the Qt platform plugin”:

Seamly2D: Setting QT_MAC_WANTS_LAYER=1 and QSG_RENDER_LOOP=basic Failed to create wl_display (No such file or directory) qt.qpa.plugin: Could not load the Qt platform plugin “wayland” in “” even though it was found. Qt: Session management error: Could not open network socket Checked locale: “en_US” INFO:Log file /home/marcosc/.var/app/net.seamly.seamly2d/config/Seamly2DTeam/seamly2d-pid2.log was locked.

Thankfully there nothing seems to be disabling the use of the program so I’m sure it will be solved in a future update without forcing it as a priority.