New Seamly2D v6 test builds for Windows, OS X, and Ubuntu!

Start 2018 with a new Seamly2D v6 test release!
Windows DownloadUbuntu InstallMac OS X Download


I just downloaded it :slight_smile: Have to look at it tomorrow though; my last version of Valentina obviously noted bigger than 0.6.0, so my pattern’s aren’t read (but hey, I wanted to straighten them up anyway since I’ve learned a lot :slight_smile: )


This is a Seamly2D version. It doesn’t have the latest bugs from Valentina.

1 Like

Well done!

The link for Mac OS is wrong (404), it looks like there is an underscore at the end of the link and it shoudln’t be there.

There is an error message, but I still can work, it doesn’t seem to be to bad: Screenshot_2018-01-05_10-22-52

Oh, and I can open my old tape-files :clap: Wouldn’t have liked to type that in again. I love the option of separate family- and given name :slight_smile:

1 Like

Thanks @ronanletiec - We are updating the version tonight to v0.6.0.1, so new links will be posted tomorrow.

@moniaqua Can you run seamly2d from a command window?
Then cut & paste the error messages here. Thanks!
Also, what is your operating system (Ubuntu, ArchLinux, Mac OS X) and version?
There is a qt bug related to _gtk_load_iconthemes.

Sorry, I forgot that. Seamly2d on ubuntustudio 16.04

The messages when I run seamly2d from the terminal are
moniuser@monitosh:~$ seamly2d
Checked locale: "en_US"
DEBUG:Log file /home/moniuser/.config/Seamly2DTeam/seamly2d-pid11692.log was locked.
DEBUG:Clearing old logs
DEBUG:Version: ""
DEBUG:Build revision: unknown
DEBUG:"Based on Qt 5.5.1 (GCC 5.4.0 20160609, 64 bit)"
DEBUG:Built on Dec 23 2017 at 22:56:54
DEBUG:Command-line arguments: ("seamly2d")
DEBUG:Process ID: 11692
DEBUG:Checked locale: "en_US"
DEBUG:Initialization property browser.
DEBUG:Initialization groups dock.
DEBUG:Can't get tag Groups.
DEBUG:Updating recent file actions.
DEBUG:Autosaving each 1 minutes.
DEBUG:Reading settings.
DEBUG:Set current name to ""
DEBUG:Autosaving pattern.

but - the error doesn’t show there. Hmm. I think I’ll have to watch that a bit

It’s not an error that’s generated by seamly2d, it’s generated by your operating system, Ubuntu Studio 16.04. I think it’s a bug with Qt when running on Ubuntu Studio. I’ve seen messages that there is a problem with this on Arch Linux.

1 Like

Hi all, thank you very much for the progress that’s been made in the Seamly2D and SeamlyMe and for making them available. I can’t tell you how much I am enjoying the program - it’s absolutely amazing.

I’ve picked up a small problem since the previous Seamly2d upgrade which didn’t always happen, but since the latest test build, it seems to be happening with all my patterns. When closing the pattern using the Menu/Windows/Close pattern, I get an error:


The ID number changes with whichever pattern I’m closing and I can even find the number if I open the file in a text editor, and it’s always on the same line of code:

I’m using Windows 10.

The only way I can close a pattern is to close the program, which is a bit irritating since I’m trying to open, check and save my important patterns from Valentina to Seamly and tidy up a bit :slight_smile:

1 Like

That’s right :slight_smile:

1 Like

I tried installing the ubuntu Seamly test build on a machine where Valentina (dismine development ppa) is already installed. I got some errors which I expected. Do you intend that Valentina needs to be completely uninstalled before Seamly can be installed?

Here is the most relevant error - I can provide the entire transcript if someone needs it.

Unpacking seamly2d (0.6.0ubuntu1-0~201712270753~ubuntu17.04.1) …

dpkg: error processing archive /var/cache/apt/archives/seamly2d_0.6.0ubuntu1-0~201712270753~ubunt u17.04.1_amd64.deb (–unpack):
trying to overwrite ‘/usr/lib/x86_64-linux-gnu/’, which is also in package valentina 0.5.999+60+3+201712171139~ubuntu17.04.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I did uninstall it, I got the same error message. Usually I have two partitions for linux on my PC, so that I can install one while the other is still intact (I do not do real upgrades of the system, I set it up new). So if I wished I could put Valentina on the other partition (needed to set up a linux there, though).

1 Like

I have several partitions on mine including an actual windows installation. I am curious about whether the goal is to let the two coexist on the same linux install, which I understand would take significant effort. The answer may be “no, that is not a goal” I just wanted to ask the question. One of the things I have talked with @slspencer about is the possibility of doing some testing of Seamly (Valentina when we had the conversation) in different OS environments.

I understand that many people who would like to use Seamly will not want to even know the question “what operating system and what version do you use”. Those people just want the computer to “work” and not be complicated. Imagine that.

1 Like

I don’t need to imagine, I know that kind of people and I have to admit that I understand them :sweat_smile: But I also know that windows and linux have a total different approach. So I guess that there will always be things that have to be different for different OS.

What is the benefit if Seamly and Valentina coexist on one PC, in one OS environment?

1 Like

My thoughts on the question : In the future, when the two programs will have different functions, people might want to use Seamly for one task and valentina for another. And in the very near future, they might just want to try both programs and see which one they prefer.

I would rather ask the questions : Why shouldn’t they be able to coexist? Why would we force the user to only use one?

I see your points, @ronanletiec Also if we ask

for me is the question, and that was why I asked for the benefits, there would be the point

It is a hard decision to do, because to determine whether the effort is worthwhile is a real tricky question and frankly, I am glad that I do not have to make that decision :slight_smile: