Pattern piece not resizing when selecting different sizes - help!

Hi gang, I seem to have hit a brick wall! I’m starting to make pattern pieces from my drafting board but the first one I’ve done isn’t resizing when I select different sizes. The size on the label changes but the actual size of the piece doesn’t! Any ideas?

Here’s the file, please don’t judge me on how ridiculously messy it is! It’s been a very complicated pattern :see_no_evil: Bias Nape Cowl - Copy.val (173.9 KB)

And my measurements: RIR Bodice Sizes 6-22.vst (8.3 KB)

1 Like

Hi, @hayleyneil

I’m trying to open the pattern, but the measurement file is missing some of the measurements used and, once I’ve added them, I’m getting critical errors:



I checked through your pattern and it’s resizing just fine from size 42 through to 66. Below size 42, there are some problems, and I didn’t check above size 66. Here’s a short video clip showing how the bodice pattern resizes:

So this tells me that, as long as the added parts are connected to the bodice front and use measurements that have a base value and increment, it should resize just fine :slight_smile:


Hi Grace, thank you as always for getting back to me so quickly! Yes the pattern is re-sizing on the drafting board, but on the ‘Piece’ page it’s not resizing. Here is a slightly older version of the file, when I had some old pattern pieces on the Piece board from when I was first learning how to do it; when I choose different sizes, those original pattern pieces resize accordingly but the new one (labeled Bodice Front) doesn’t! I have no idea why this would be happening :cry: Bias Nape Cowl - Copy - Copy.val (179.4 KB)

1 Like

Just an observation… it would be better to rename (or saveAs) the file name so we can tell it’s a different file, and not just a copy of a copy of a file. :slight_smile:


You’re absolutely right, just laziness on my part! :see_no_evil:

1 Like

Okay, so I’ve just tried to open the files again and it’s now not letting me open either of the ones I just posted above! I could cry, I spent so much time on this pattern but it just seems to be corrupting each version one by one! This is the message I’m getting:

Does this mean there’s no way back and I have to start all over again?

1 Like

I’ll remove the pattern piece which will clear up the error but then I won’t be able to test the pattern piece to see if it resizes or not :rofl:

A catch 22 again.

Let me see what I can do.


Ahh okay thanks so much Grace! I didn’t know you could remove the pattern piece to clear the error! Maybe after you’ve done that I could just try making another random pattern piece and see if that resizes once it’s on the Piece board. I already attempted that two or three times though and the same thing kept happening… total nightmare! Thank you x

1 Like

:rofl: Shame, man. Did you, perhaps, use the Union tool when you made any of the pattern pieces in Piece mode?

Nope, I have avoided it like the plague since you warned me to do so! I just made the pieces as I normally would with the New Pattern Piece tool. No idea why this pattern should be misbehaving so awfully when the other ones I’ve done have all been fine!

I’ve taken out the 3 offending pattern pieces & tested the resizing on the front bodice.

Size 42: image

Size 46: image

Size 50: image

Size 60: image

Size 70: image

They’re resizing just fine in this file:

Bias Nape Cowl - Copy - Copy.val (179.4 KB)

I’m going to check the other one now.

I’ve deleted the pattern piece on this pattern. Now it only has the test square in Piece Mode.

Bias Nape Cowl - Copy (1).val (171.1 KB)

I checked the pattern in Draw Mode and it does resize nicely.

Once you have created the pattern piece again, set your screen size to a comfortable size and then resize the pattern in large numbers. I start at 40 & then 50, 60, 70. If size 40 fits onto the screen, then you’ll notice the other sizes will edge off the screen. Don’t adjust your zoom to fit, just change the size and see the difference.


As always, hugely appreciate you taking the time to help, thank you! Yes the original pattern pieces (as in the one you show above) were resizing fine, it was just a new one I had made that wasn’t working. I’ve just made it again on the file you sent through and it’s still not working! If you choose different sizes, the number on the pattern label changes, but the size of the piece doesn’t. Aargh! Here it is: Bias Nape Cowl - Grace.val (168.1 KB)


Once again, I get errors in opening this pattern, so I decided to check why your pattern pieces are causing a problem each time the pattern is closed and reopened. While I was checking, I created a portion of a pattern and yes, it doesn’t resize in Piece Mode, but I think it’s related to what I found with the Critical Error of the pattern piece which I’ll report here because I suspect it’s a bug in the program.

For attention of someone with more knowledge than myself (@Douglas, @Pneumarian)

I don’t know if it’s because I moved all the pieces onto one drawing board that has confused the program or what, but the pieces that I did move over are behaving correctly in piece mode. It’s only with the later additions that it is doing this.

Anyway, here is what is happening…

Every time a pattern piece is created and the program is closed, it gives critical errors on opening.

I put a portion of the front skirt into a group so that I could identify the object ID’s, and then I created a pattern piece using only those objects. And have found that the ID’s in the group and the ID’s in the details don’t correspond.


This is where object 984 was created:

Object 1028:

        "point firstPoint="1002" id="1028" length="CurrentLength/2" lineColor="mediumseagreen" lineType="none" mx="0.132292" my="0.264583" name="A56" secondPoint="999" showPointName="true" type="alongLine"/"

So why do the object ID’s remain correct in the group, but it keeps changing them in Piece Mode? I’ve tried manually changing them, but this gives an error, too. And the incorrect ID numbers that are created are always numbers in sequence that haven’t been previously used.

Here is the pattern that I did the above testing on:

Bias Nape Cowl - Copy - A.val (186.4 KB)
RIR Bodice Sizes 6-22 (2).vst (8.3 KB)

1 Like

That could be. Like Marty going back to 1955 and changing the future time line. Lol

Maybe I have some free time this weekend to take a closer look at the before & after. BTW, I tried to open the pattern too, but it was giving the critical error, and I didn’t have time to investigate.


There are 2 id’s… a tool id, and an object id. Sometimes they are the same, but not always. If memory serves correct the Group tool only uses the tool id. Also the Groups were shoehorned into the code, so they are parsed differently than the normal tools. Without getting into the weeds, the groups always parse from the Dom Document, where other tools are parsed, and added to the data container (by object Id)… so tools with an obj Id don’t always need to be reparsed all the time from the document, where groups do. Off the top of my head there could be discrepancy where the obj ids are not being updated like the group tool id’s are? Just a guess.

Also as a “Group” aside… do to the fact that the groups are constanly reparsing - which I noticed previously while running in debug mode where you can track debug msgs in the console output - things can start to slow down when lots of tools are grouped and there are lots of groups. I need to figure out how to reduce the group parsing - or refactor the Groups in more efficient fashion.


Thank you, @Douglas

I spent the whole 2 hours of loadshedding checking it out. I deleted the large groups and the offending pattern pieces.

What I have now found is… it’s not creating the “Modeling” for the new pattern piece where it converts the ID’s to Objects… Only the “Detail” - and this is why it’s creating the critical error and can’t find the Object ID’s.

Anyway, I have people coming over so I’ll check it out again a bit later.

1 Like

Ok, I deleted all the groups and pattern pieces in Seamly. Added only a portion of the new parts and it has created both the Model & the Detail just fine and it resizes.

My guests have arrived, so I’ll recreate the other bits later and keep everyone posted :slight_smile:


Guys, I cannot thank you enough for your efforts in trying to work this out for me. Even though it literally sounds like you’re talking another language to me!