Problem with Workpiece tool! Please help!

Hello, I just started learning Seamly2d and I’m having issues with workpiece tool. Somehow I just can’t select the whole bodice pattern, instead of making a curve around the neck or the armhole it draws a straight line. I have also tried holding the shift key button when selecting the curve in order to make it in clockwise direction but it’s not working.

Also when I press enter after selecting the points with the workpiece tool and it opens this section for seam allowance, labels and pins I can’t go on the second tab to add seam allowance on my pattern.

Thank you in advance!


Hi, can you zoom in while selecting the curve? It should become bold, then you can select it. Once you have this window pop up, just click ok on the first tab. Then go to “details”, select the piece you just made and right click, this will lead you to options. That is where you can add seam allowance.

details 8


Thanks a lot for your answer :slight_smile:

1 Like

In addition to what @AVI said, I will note that arcs should always have a counter-clockwise rotation, which in the case of the displayed arc means that it is already clockwise in relation to the path around the pattern piece.

Also that you can reverse the direction of a curve in the Options of the Detail in addition to using Shift when selecting it.


I’m having similar trouble! Even when I zoom in and the curve is bolded I can’t select it, and I don’t see the workpiece tool pop-up until after I’ve finished selecting everything.


My best advice here is that often the curves go in such a way that they “disappear” from the main outline of the pattern before it has been pursued a bit further. If you click it twice it will un-select, you can’t click & then shift-click the same node. So just patiently click your way around the outline & hopefully it will look right at the end.

Hopefully that works for you. If not, post a copy of the .val & the .vit, your seamly2d version, (a screen-cap of the About screen is preferred,) & which OS you use & hopefully one of the dev team can figure out what the bug is.

Once again, I hope that something, (hopefully in the first paragraph :worried:) that I posted was helpful for this issue. Good Luck!



You can always use the node tool insert_node@2x

to add a point or curve that you may have missed. Then in the Workpiece Tool Dialog->Paths you can change the attributes (reverse, notch, excluded) of the added node object and then drag / move it up to the correct order it needs to be.

Also note that if you place a notch on a curve, you need to select the curve, the notch, then the curve again… like this:Screenshot (379)

otherwise the program will draw the curve to the notch, then a straight line to the next point… like this: Screenshot (381)


For now…

Yes. Hold down the ctrl key while using the mouse wheel. Or you can gesture on a laptop trackpad no ctrl key required. I just tried Seamly on a new touchscreen laptop for the 1st time, and apparently there is no touchscreen support for zooming yet.


@Douglas is correct, there is no touchscreen support yet :crying_cat_face: Added new github issue here:

NEW UI/WORKFLOW: Touchscreen support · Issue #296 · FashionFreedom/Seamly2D · GitHub


I have a pen tablet that I use mostly with Inkscape-Inkstitch for embroidery designs making and the zoom doesn’t work with my pen tablet in Seamly2D


Well, having tested the notch updates on the touchscreen laptop,I now have somewhat an idea how the app runs using a touchscreen. I’ll need to build a release of my fork (I usually build in debug mode and don;t have anything recent) and run it on the new laptop, as I added the gesture support awhile back… not realizing it’s really for touchscreen and not the trackpad. Doh. So I may have already fixed touchscreen support… or not. :slight_smile: