Propiedades de la Herramienta Point intersect XY

Yo de nuevo :see_no_evil: :upside_down_face: :slightly_smiling_face:

En la herramienta Point Intersect XY, cuando le doy clip derecho para trabajar con sus propiedades, se me muestra asi,(ver imagen), no se puede modificar la ventana y no se pueden ver las opciones.

Me again :see_no_evil: :upside_down_face: :slightly_smiling_face:

In the Point Intersect XY tool, when I give it the right clip to work with its properties, it shows me like this (see image), the window cannot be modified and it cannot be see the options.

PUNTO INTERCEPCION XY

Sin embargo desde la ventana del editor de propiedades si se muestra correctamente.

However from the property editor window if it is displayed correctly.

PUNTO DE INTERCEPCION XY

3 Likes

Cuando es su release date y de que OS?

When is your release date & which OS?

:unicorn:

1 Like

Hola

Release Date: 03/27/2023

OS; Windows 11

2 Likes

Unfortunately the original dev chose to use 2 different ways to handle the Dialogs and the Property Editor so while I have made them closer in look and function, there may still be some differences that need to be fixed.

3 Likes

I can not confirm this issue using the Apr 3rd 64 bit Windows build. Try updating to the current ver, and see if it fixes the issue.

2 Likes

HOLA :slightly_smiling_face:

Actualice a la ultima version de Seamly 2D

Upgrade to the latest version of Seamless 2D

VERSION DE SEAMLY

y sigue el mismo problema.

and still the same problem.

PUNTO DE INTERCEPCION

2 Likes

Hmmm… I’ll take a look at the dialog form to see if I find anything that may be causing the error.

Anyone else experiencing this issue with the XY tool?

2 Likes

Checking with the 20230424 AppImage on Devuan Linux: Same issue, but not as bad.

:unicorn:

1 Like

I looked at the form… I think I got it fixed. I redid the IntersectXY dialog awile back, so it was formated a bit different than the recent updates to the rest of the dialogs. The dialog height policy was “fixed”, meaning if the OS changes the font size larger than 9 point, it squashes the top groupbox to fit in the fixed height. DOH.

I changed the height policy to “preferred” (like the rest of the dialogs), increased the height by 30 pixels, and added a vertical spacer… so it should expand if the font size is larger.

3 Likes

@Douglas Is this fix the PR you created today?

1 Like

No. In fact I just made a PR for this fix now. BTW… I’m liking the what-the-dif bot. :slight_smile:

2 Likes

@Damay

Looks like Susan has already merged the changes that should fix this. When you update the app, let me know if indeed it does fix the issue for you. Please don’t hesitate to let us know if any other dialogs exhibit the same issue.

2 Likes

Hola @Douglas.

Muchas Gracias a todos por tomarse el tiempo en arreglar algo menor, en comparacion con todo lo demas en lo que se esta trabajando en Seamly 2D.

Como pedistes, aca tengo una actualizacion.

Ya instale la ultima version

La ventana se ve como la muestro en la imagen. Se ve un poquito mas que antes, pero no completamente. Y no se puede expandir o ampliar.

Hi @Douglas.

Thank you all so much for taking the time to fix something minor, compared to everything else being worked on in Seamless 2D.

As you requested, here I have an update.

I already installed the latest version.

The window looks like I show it in the image. It looks a little more than before, but not completely. And it cannot be expanded or enlarged.

2 Likes

Ok. I’ll take a look again… I think I may know what’s causing that groupbox to not expand.

BTW… can I assume you have changed the text settings to 125%? Which would cause the text to take up more space than the dialog allows. If that’s the case then I can switch my system to 125% to check that the dialog is working correctly.

2 Likes

No se muy bien donde pudiera cambiar la configuracion de texto. Entonces indica que no he tocado nada que tenga que ver con eso. Me pudieras mostrar con una captura de pantalla , donde seria?

I don’t really know where I could change the text settings. Then it indicates that I have not touched anything that has to do with it. Could you show me with a screenshot, where would it be?

1 Like

I’m using Windows 10, so I’m not sure what the “settings” look like with Windows 11… but here’s where the you can change the scale and resolution of the System,->Display

Changing the scale makes the system font larger - that is easier to read.

That being said, I was able to fix the issue… I had the Selection group box height minimum set, so it was squashing the contents of that box. I checked with my Display set at 125% so ithis one is fixed. I did notice some other display issues at 125% in some other dialogs. I’ll address those as I’m updating the dialogs to add a group attribute.

3 Likes