QObject::connect: Invalid null parameter on open

I received the error “QObject::connect: Invalid null parameter” after trying to adjust “point along perpendicular” and Valentina closed down. Now my .val file gives that same error every time I try to open the file. Kapell3.val (4.8 KB)

Using Valentina

Can you tell how exactly? What did you do?

If you look into file Kapell3.val (with an editor), I was modifying the last (all using Valentina . not direct edits of the file) , possibly point id=“65” which cannot be seen anymore in the file, and its length was taken from the length of "point id=“63”. I was going to re-edit “point along perpendicular” (point 65) as the program crashed. I can only replicate to above error now by trying to open the file. The same happened on a separate file containing ovals and arches. It wasn’t my bad luck as it happened again as in the attached file. References to objects missing perhaps? Illegal characters?

Stop. You are talking about internals. Did you edit the file manually?

No & Yes. The file you are looking at has not been tampered with manually.

In this case i need a way to reproduce the bug. You are talking that this happened after you “adjusted “point along perpendicular””. What exactly you did? Can you repeat it? Also i see a problem with detail in this file. Maybe bug that you see is happening because file already corrupted. You can try to create a detail again and see if it will work.

I will send you another file that I can successfully open. Go into Draw detail, choose pattern piece “MidTunnel”, use the “Seam allowance tool” for that piece. Move to Details add a seam allowance. Save the file and try to reopen it. For me that gives an error message. Kapell7.val (5.8 KB)

Please, update your test version to the last.

What should be different now when on Monday 27th distribution (amd64)? When trying to select piece C or D for seams Valentina just closes down on enter, without any messages. I am using Kapell7.val as a base. Same reaction with earlier version when using seam alowance tool.

First i want to be sure you are using the latest published test build.

I can’t repeat this bug. Can you made a record? Or gif image?

I will remove the video after a few days ok?

Good. That’s much better!

I will remove the video after a few days ok?

You can do it even now. I reload into the forum.

I downloaded the test version for windows (on win 8.1) and it worked ok. Smooth and nice as should be. Same files work cross platform. The problems appear on Ubuntu 16.04 LTS, Gallium 0.4 on NVE7, 64-bit. I used the AMD64.deb file.

The file edited on Windows was loadable in Ubuntu.

Looks like this is somehow related to 64 bit version only.

I agree! An hour ago I installed the i386.deb version. Userinterface looks slightly different and has no problems! I think that my Ubuntu is amd64 installation. Don’t know how to check - to me it does not matter. Thank you dismine for looking into this - If left alone I might have left this application alone. Excellent app - changes the business of clothing.

Left it to me. I will find way.

The bug was fixed.:relaxed:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.