Seam allowance "without a corner"

Hello there,

it’s not a major problem right now but I am curious anyway: what shall I do when my seam allowance is generated “without a corner”, as on my picture here? image

Did I do something wrong when creating the pattern piece, perhaps?

There seem to be nothing specific on the seam allowance definition around the point A75: image

I don’t really care now, when cutting manually. But I hope to switch to a machine cutting one day and this wouldn’t be ok.

Thanks a lot!


Did you try changing the “Angle” setting at node A75? This determines the miter (if any) at a corner.

You can also try changing the order of which main path node is first in the list.

It’s also possible this may be an edge case, where a mitre routine fails to find an intersection and produces an incorrect mitre. I’ve found other examples where this is due to the fuzzy math… something I need to look at further.

1 Like

Thanks a lot @Douglas, it was the miter, really! I haven’t noticed till I zoomed really close:

Once I’ve fixed this, the seem allowance looked ok: image

So it is solved, have a great day!


Yup.That will do it too. The loop in the curve was causing a line to extend in the wrong direction so it could not find an intersection with the side seam cut line. Glad you figured it out.


Ok, I obviously misunderstood what you’ve meant by “miter”, sorry :slightly_smiling_face:. I thought it is the end angle of a curve. Nevertheless, it’s fixed now.


Mitre being the shape of the corner. Changing the node “angle” (which IMO is misnamed) changes the shape of a corner.

In your case the control point of the curve was flipped 180 degs, which caused a looped, which resulted in not finding the desired corner shape. It happens… so if you ever have a seam allowance that is not working, a curve’s endpoint control point position is a thing to check.


@Douglas Hi, Happy New Year to All. I am having similar issues with seam allowance corners. There are no curves in/out from the point (A6) but corners in seam, allowance is missing. Checked curve at A4 and it does not loop. I have the latest version. I tried all options under angle drop down field. Does not fix it. A6 - Created using point tool (intersect line-axis) A4 - Created using Arc tool (intersect Arc-axis)

Any suggestions, Thanks



This is another anomaly with the seam allowance. Not exactly sure why it does this, but at some point when the angle gets too acute, the corner is clipped. It will also do strange things when the seam allowance is on the inside of an accute angle. Don’t have any suggestion at the momment until I’m able to look at the corner routines and figure out what the original dev was doing with the geomety. As long as there are no loops at the node, it’s not going to cut off the SA like with the pics in the original post.


Thanks Douglas. It is manageable for now.


i think there’s a similar problem. (if not i can make a separate query) i am on version for Mac build on 4th Mar. 2024

when i am exporting the piece A29-A34-A36-A27 the point A34 goes off. none of the point property options work

additionally the notches option doesn’t work either . i tried it with all the pieces. it doesn’t work

1 Like

Welcome to Seamly @K.Prasad

I’d have to look at your original pattern with its measurement file to be positive, but the problem with your point A34 appears to be that it’s not actually on the curve.

Unfortunately, I’ve run out of time today. Someone who can explain better should be by in a bit. If not, I might have time tomorrow.



Hi @K.Prasad,

Can you post your pattern file and any measurement file so one of us can take a look.

Or possibly the control point is 180 deg backwards.


that was it, it looks like it on the curve but it wasn’t. thanks