Window position on mac

Hello everybody, since the last update, I have an error when I open Semaly2D

If I Press op, the error occurs once again and than I have the screen like that

What can I do to overcome this problem

1 Like

Hello, @H.Naehmann

Perhaps @Douglas or @Pneumarian can help you with this one.

1 Like

I would suggest to rename the Seamly2DTeam/Seamly2d.ini settimgs file… not being a mac user I don’t know where the path to that folder is? Best I can make out is .

$HOME/.config/Seamly2DTeam/Seamly2d.ini

By renaming the settings file it forces the app to start with a blank slate. Of course you’d lose any settings, but could confim whether that’s the issue.

Thing is I’ve never seen this error with Windows, and I’ve built the app 1000’s of times. Only recent changes have mainly been to SeamlyMe and the Welcome screen. Maybe @csett86 or another mac user can have a look to confirm if this is an issue on the MacOs?

3 Likes

I‘ll cross-check tomorrow on my mac with the latest Seamly

4 Likes

Just to be updated, any news from your cross check?

1 Like

I checked and I dont get any error when opening the latest Seamly2D. As I see negative coordinates: Could it be that you once had an external display attached and moved Seamly2D there and then closed it? Background: Seamly2D tries to open at the last location on screen…

1 Like

@csett86 ,

Thanks for your answer, but I never had an external display, i use from the be beginning a MacBoook 13 .

1 Like

Then I am also lost for ideas, unfortunately

That’s why I suggested to rename (rather than delete) the seamly2d.ini settings file, as the main window geometry is saved there. That way the settings are cleared, and there shouldn’t be any invalid window geometry saved.

2 Likes

@csett86 , thanks for your answer, but I don’t know what to do with the suggested renaming of the setting file, esp. where to find that file. As I mentioned before I’m not a IT Specialist, I’m a User, in Privat life I Use Mac, esp while working with Adobe Photoshop and Illuistrator, and at work in my hospital we have windows devices, for the Hospital information system, Patients file etc. etc.

Whenever there is a Problem we have a It support taskforce, for that. I’m Vascular surgeon in a full time job, with long working days, and additonal on call services. So sewing and Pattern construction is my hobby and I do that in my Leisure time. When looking around for a pattern making programm I came across Seamly2D. which I though was easy after having seen all the tutorilas from Dina Werthenbach. We both learned pattern constructioni with Müeller und Söhne, that made it easy. but lookig back - using this programm becomes more and more timeconsuming - for me as a Mac user as there are always new problems after each update.

And as a last point to mention, the german translation was something which happens when many people at diffent places with differenrt knowledge levels and different doing a project. For a projekt like that you have to have a team and need projectmanagement. To make sure what has to be done, who takes which tasks on, the time frame an regualr updates and quality controll. At the end, for me it was a lot ofe new input as I thougt just translate the words from English into German, sending you a list an someone who ist in that businiss as programmer. And when I srtarted there were already translations (with a lot of errors) and literal translations which are not used in our language. Then it was not clear whether we use the modern saluation you means Du in German, as it is usuall in every part of our life even in Companies. Or do we use the respectfull saluation you which means SIe. There was a colourfull mixture of these two ways, etc. etc. at the end there where errors in the translations, as DIna found out - and I was asked for the mistakes. Well and as I read at the side bar this topich has been solved. QUestion is for whom is it solved?. Not for me.

1 Like

Hey Guido… again… not being a Mac user myself I don’t know the folder structure of the mac system. All I can accertain is that the path to the settings file is

$HOME/.config/Seamly2DTeam/Seamly2d.ini

I don’t know what the $HOME part if the path is. :frowning: I have my suspicians that the settings saved some weird main window setting / size. The problem is unless you delete / rename the file, reinstalling the app will just use the same Seamly2d.ini setting file. Also we’re not sure the settings are the problem. That’s why I suggest to just rename the file so you can just rename it back if it’s not the issue, and not have to set all the preferences again. If it is the problem, then you have to delete it or edit out the bad part.

1 Like

$HOME is the folder that clicking on the Home button takes you to. Occasionally referred to as the “user-root” folder, because although it is not foundational to the System, it is foundational to the individual user’s use of the machine. In my experience *nix systems generally implement this smoothly, whereas Windows10 implements it like a wrecking ball in a greenhouse.

@H.Naehmann On *nix systems, including Mac, files/folders whose names begin with a period default to invisible. There may still be a setting to show hidden files, or you may need to get into the Terminal. @csett86 would know. You could also try running a find on your computer for Seamly2DTeam if Apple hasn’t neutered that function.

:unicorn:

1 Like

Hi, this seamly2d.ini file is hidden in Mac. You can see hidden/invisible files/folders by pressing: command + shift + dot(.).

Go to your home folder in Finder → machintosHD (or whatever is your computers name for it) and press (command+shift+dot) then you see hidden folders. Then go to Users → under user there is (.config) folder → from that folder you find (seamly2dteam) folder → in that folder there is the seamly2d.ini file.

And with same command+shift+dot you can make them invisible after.

4 Likes

@03Pencil , @Douglas, @csett86, today is a good day, as I solved the problerm.

$HOME/.config/Seamly2DTeam/Seamly2d.ini was located on a different place, but with the command @03Pencil texted, it was quite easy ti find, at the end I deleted the file and the problem with the window was solved, also the problem with the Piece Proberties,.

So thanks to all of you for the support, by the way, Am I the only macuser, who has problems with the programme, or are other macusers, already frustrated or depressive. And my mcbook still running with macOs Monterey, I have not updated to macOs Sonoma.

But as I work now with Seamly2d in the german version I came across a few Surface problems.

BUt I thing I will start a new topic with this problems.

Thanks again

2 Likes

Glad this solved the issue. I had a hunch something messed up in the settings file.

1 Like