Zoom Seems a Bit Twitchy

Does anybody have any tips for controlling zoom-out? I’ve figured out that double-click will zooms out when I want to. But it seems a bit twitchy when I’m just working. For instance, I’m trying to adjust a curve and suddenly it zooms all the way out. Trying to see the labels at the top of my pants pattern, zooms all the way out. I’ll try to keep track of exactly what I’m doing to see if I can duplicate it. But hopefully, I’m just doing something wrong.


Double-clicking anywhere on the workscreen zooms to fit, (the entire workpiece.)

Curve manipulation is also the place where I have to remember to slow down so that two consecutive clicks don’t read as a double-click.


1 Like

Not sure what you mean when you double click it zooms out? It should be zooming in to fit the current draft block in Draft mode or the pattern piece in Piece mode when you double click.

Are you using a mouse? If so the scroll wheel is the best way to zoom. You can configure to use CTRL or Shift as to whether it switches the wheel to scroll. This can ve set in the App Orefs → Graphics-> Navigation. You can also set the Speed of the zoom here. Maybe this is where you need to set a lower speed? Keep in mind when using the wheel to zoom it will center the view on the mouse position.

If using touch screen you can just pinch to zoom in / out.

The + and - keys will also zoom in and out.

The only place where things still get “twitchy” is when moving a pattern piece in Piece mode. Haven’t been able to figure out why it keeps zipping away when a piece hits the view edge.

1 Like

Yes, by zoom, I meant shows the whole piece. I looked at the Navigation controls. I’m already using Ctrl-mouse wheel. Mouse wheel by itself scrolls up and down. I decided to turn off the double-click behavior for now and slowed down the speed of anything I could. Thanks for the help.


In that case if you hold the Ctrl key while while moving the wheel, the view will zoom instead of scroll. You can toggle this option to switch the behavior.

1 Like