Install abort (on Ubuntu 16.04 LTS) - solved

Hello !

I tried to install Seamly2D (Ubuntu 16.04 LTS), but everytime I try to install it, i’m getting this :

$ sudo apt-get install seamly2d Reading package lists… Done Building dependency tree Reading state information… Done The following packages were automatically installed and are no longer required: libllvm5.0 linux-headers-4.13.0-37 linux-headers-4.13.0-37-generic linux-headers-4.13.0-38 linux-headers-4.13.0-38-generic linux-image-4.13.0-37-generic linux-image-4.13.0-38-generic linux-image-extra-4.13.0-37-generic linux-image-extra-4.13.0-38-generic Use ‘sudo apt autoremove’ to remove them. The following additional packages will be installed: libmotif-common libqt5xmlpatterns5 libxm4 xpdf The following NEW packages will be installed: libmotif-common libqt5xmlpatterns5 libxm4 seamly2d xpdf 0 upgraded, 5 newly installed, 0 to remove and 1 not upgraded. Need to get 5 266 kB of archives. After this operation, 79,9 MB of additional disk space will be used. Do you want to continue? [Y/n] Y Abort.

I don’t know why.

I did use the command that are advised before this one (sudo add-apt-repository ppa:susan-spencer/seamly2d sudo apt-get update)

Thanks to anyone who tries to help me !

1 Like

Hi @ElleyLean!

Portions of your Ubuntu kernel, including linux headers, were automatically updated on your computer. When this happens, they don’t delete the replaced filesso you can rollback if you choose.

After an automatic update, the next time you manually install a package (with apt-get command) you’ll be informed of all the automatically replaced files so you can choose to remove them or not. You’ll also be informed of the files to be manually installed. It’s confusing at best, you’re not alone in being concerned.

Here’s the best over-arching explanation I’ve found so far: Why does apt-get think packages "are no longer required" - Unix & Linux Stack Exchange

So, go ahead and press Y if you dare! :slight_smile:

1 Like

Yes, I did press Y (I pasted the result with the “Y” to show that ^^) But, after that, the console show “Abort.” and stop. Everytime :confused: I’m used to Ubuntu, but never saw that :confused:

1 Like

Ahah, after days trying to install, today it works XD Sorry for the useless post, must have had no luck the other days. ^^

Have a nice day !


Looks like there’s something going on within your terminal command window so that it can’t read from stdin (standard input is typically your keyboard).

Try this command to auto install without typing in a response: sudo apt-get -y install seamly2d

I wish we could help you further, but this probably is an Ubuntu issue. To get help with troubleshooting, you can post a detailed question on Ask Ubuntu. Here are some guidelines for asking a good question to increase the odds that you’ll get an answer: How do I ask a good question? - Help Center - Ask Ubuntu

Good luck, keep us posted on what fixes your manual apt-get install issue.

1 Like

Wow, just noticed that your problem spontaneously resolved itself!


1 Like

Yay yes ^^ Thanks for your help anyway. :3